sys-kernel/dracut: Update live ebuild
authorAlexander Tsoy <alexander@tsoy.me>
Mon, 9 Mar 2020 23:21:20 +0000 (02:21 +0300)
committerMike Gilbert <floppym@gentoo.org>
Tue, 10 Mar 2020 19:49:56 +0000 (15:49 -0400)
Signed-off-by: Alexander Tsoy <alexander@tsoy.me>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
sys-kernel/dracut/dracut-9999.ebuild

index 192c964420407c433f7ca4f279514435ad5abf4f..f34a9db579a213380a429d243e91217344086864 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -11,7 +11,7 @@ if [[ ${PV} == 9999 ]] ; then
 else
        [[ "${PV}" = *_rc* ]] || \
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-       SRC_URI="https://github.com/dracutdevs/dracut/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://www.kernel.org/pub/linux/utils/boot/${PN}/${P}.tar.xz"
 fi
 
 DESCRIPTION="Generic initramfs generation tool"
@@ -31,7 +31,7 @@ RDEPEND="
        >=sys-apps/kmod-23[tools]
        || (
                >=sys-apps/sysvinit-2.87-r3
-               sys-apps/openrc[sysv-utils,selinux?]
+               sys-apps/openrc[sysv-utils(-),selinux?]
                sys-apps/systemd[sysv-utils]
        )
        >=sys-apps/util-linux-2.21
@@ -64,6 +64,7 @@ DOCS=( AUTHORS HACKING NEWS README.md README.generic README.kernel README.module
 QA_MULTILIB_PATHS="usr/lib/dracut/.*"
 
 PATCHES=(
+       "${FILESDIR}"/050-gentoo-ldconfig-paths.patch
 )
 
 src_configure() {
@@ -79,7 +80,7 @@ src_configure() {
        echo ./configure "${myconf[@]}"
        ./configure "${myconf[@]}" || die
 
-       if [[ ${PV} != 9999 ]] ; then
+       if [[ ${PV} != 9999 && ! -f dracut-version.sh ]] ; then
                # Source tarball from github doesn't include this file
                echo "DRACUT_VERSION=${PV}" > dracut-version.sh || die
        fi