app-admin/setools: add python3_7
authorJason Zaman <perfinion@gentoo.org>
Fri, 29 Nov 2019 16:22:40 +0000 (00:22 +0800)
committerJason Zaman <perfinion@gentoo.org>
Mon, 2 Dec 2019 14:48:26 +0000 (22:48 +0800)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
app-admin/setools/setools-4.2.2.ebuild
app-admin/setools/setools-9999.ebuild

index 22da7166d07829e6f6d5a789e775228aaae8b949..20bb81b9fcd1241dd15368392f74df10f5e57996 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
-PYTHON_COMPAT=( python3_5 python3_6 )
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
 
 inherit distutils-r1
 
@@ -20,6 +20,7 @@ fi
 LICENSE="GPL-2 LGPL-2.1"
 SLOT="0"
 IUSE="X test"
+RESTRICT="!test? ( test )"
 S="${WORKDIR}/${PN}"
 
 RDEPEND="${PYTHON_DEPS}
index 8df9cb7cd4076330cf2a3a006c4c016f025348f7..96ff5057cd8e4db8055477addde2c23c9ed79354 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
-PYTHON_COMPAT=( python3_5 python3_6 )
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
 
 inherit distutils-r1
 
@@ -20,6 +20,7 @@ fi
 LICENSE="GPL-2 LGPL-2.1"
 SLOT="0"
 IUSE="X test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="${PYTHON_DEPS}
        >=dev-python/networkx-2.0[${PYTHON_USEDEP}]