dev-python/tldextract: Initial import
authorPatrick Lauer <patrick@gentoo.org>
Sun, 13 Oct 2019 13:11:05 +0000 (15:11 +0200)
committerPatrick Lauer <patrick@gentoo.org>
Sun, 13 Oct 2019 13:15:22 +0000 (15:15 +0200)
Transitive dep of app-crypt/certbot-dns-nsone
Ebuilds taken from adjust gentoo-overlay

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
dev-python/tldextract/Manifest [new file with mode: 0644]
dev-python/tldextract/metadata.xml [new file with mode: 0644]
dev-python/tldextract/tldextract-2.2.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/tldextract/Manifest b/dev-python/tldextract/Manifest
new file mode 100644 (file)
index 0000000..f68f73e
--- /dev/null
@@ -0,0 +1 @@
+DIST tldextract-2.2.1.tar.gz 54538 BLAKE2B 0abfb1982d0b9e9cd767bc64db289da8bf2f58b599eaea7e703adf36934dae0d052170fa9a8205b8ac0b441d8f1ac75648ccc108515586b0bcacf2ecb43fef52 SHA512 db4f14e514c0e68f85f28226343d7ec91ceea2843ee01c9a2950f0972f365bf343640e07cfb118aff52bab975719be71d179fc6b3bd4da7eb62a47b62747cc0b
diff --git a/dev-python/tldextract/metadata.xml b/dev-python/tldextract/metadata.xml
new file mode 100644 (file)
index 0000000..42aafec
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>patrick@gentoo.org</email>
+    <name>Patrick Lauer</name>
+  </maintainer>
+</pkgmetadata>
diff --git a/dev-python/tldextract/tldextract-2.2.1.ebuild b/dev-python/tldextract/tldextract-2.2.1.ebuild
new file mode 100644 (file)
index 0000000..8addd4d
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Accurately separate the TLD from the registered domain and subdomains of a URL."
+HOMEPAGE="https://pypi.org/project/tldextract/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/idna[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-python/requests-file[${PYTHON_USEDEP}]
+"