media-gfx/fbida: Fix building with CFLAGS=-fno-common
authorJeroen Roovers <jer@gentoo.org>
Wed, 8 Apr 2020 07:28:14 +0000 (09:28 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 8 Apr 2020 07:28:43 +0000 (09:28 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Closes: https://bugs.gentoo.org/713004
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
media-gfx/fbida/fbida-2.14.ebuild
media-gfx/fbida/files/fbida-2.14-fno-common.patch [new file with mode: 0644]

index c7ddbadf36cb7e6bbeecb20d2ff68eaab2625191..9e5d00b136d3fb8955f198669c007b74c80c9c14 100644 (file)
@@ -60,6 +60,7 @@ PATCHES=(
        "${FILESDIR}"/ida-desktop.patch
        "${FILESDIR}"/${PN}-2.10-giflib-4.2.patch
        "${FILESDIR}"/${PN}-2.14-Autoconf.patch
+       "${FILESDIR}"/${PN}-2.14-fno-common.patch
 )
 
 src_configure() {
diff --git a/media-gfx/fbida/files/fbida-2.14-fno-common.patch b/media-gfx/fbida/files/fbida-2.14-fno-common.patch
new file mode 100644 (file)
index 0000000..e2f29f6
--- /dev/null
@@ -0,0 +1,53 @@
+--- a/fbi.c
++++ b/fbi.c
+@@ -86,7 +86,6 @@ static int img_mem, max_mem_mb;
+ /* graphics interface */
+ gfxstate                   *gfx;
+-int                        debug;
+ /* framebuffer */
+ char                       *fbdev = NULL;
+--- a/filter.c
++++ b/filter.c
+@@ -6,8 +6,6 @@
+ #include "readers.h"
+ #include "filter.h"
+-int debug = 0;
+-
+ /* ----------------------------------------------------------------------- */
+ static void
+--- a/idaconfig.h
++++ b/idaconfig.h
+@@ -17,7 +17,7 @@
+ /* -------------------------------------------------------------------------- */
+-char *ida_lists;
++extern char *ida_lists;
+ void ida_init_config(void);
+ void ida_read_config(void);
+--- a/readers.c
++++ b/readers.c
+@@ -7,6 +7,8 @@
+ #include "readers.h"
+ #include "byteorder.h"
++int debug=0;
++
+ /* ----------------------------------------------------------------------- */
+ void load_bits_lsb(unsigned char *dst, unsigned char *src, int width,
+--- a/viewer.c
++++ b/viewer.c
+@@ -38,7 +38,6 @@
+ #define PROCESS_LINES    16
+-int debug;
+ Cursor ptrs[POINTER_COUNT];
+ /* ----------------------------------------------------------------------- */