net-libs/daq: remove unused patches
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Sat, 14 Dec 2019 08:01:37 +0000 (09:01 +0100)
committerAaron Bauman <bman@gentoo.org>
Sat, 14 Dec 2019 21:49:05 +0000 (16:49 -0500)
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/13978
Signed-off-by: Aaron Bauman <bman@gentoo.org>
net-libs/daq/files/daq-2.0.2-libpcap-check.patch [deleted file]
net-libs/daq/files/daq-2.0.2-parallel-grammar.patch [deleted file]

diff --git a/net-libs/daq/files/daq-2.0.2-libpcap-check.patch b/net-libs/daq/files/daq-2.0.2-libpcap-check.patch
deleted file mode 100644 (file)
index b68a8a4..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-fix the libpcap check so that people can set the cache version when cross-compiling
-
-patch by Shawn Wallace <sjwallace@google.com>
-
---- a/m4/sf.m4
-+++ b/m4/sf.m4
-@@ -135,7 +135,7 @@
-         echo
-         exit 1
-     fi
--    AC_MSG_CHECKING([for libpcap version >= $1])
-+    AC_CACHE_CHECK([for libpcap version >= $1], [daq_cv_libpcap_version_1x], [
-     AC_RUN_IFELSE(
-     [AC_LANG_PROGRAM(
-     [[
-@@ -147,16 +147,13 @@
-         if (strcmp(pcap_version, $1) < 0)
-             return 1;
-     ]])],
--    [libpcap_version_1x="yes"],
--    [libpcap_version_1x="no"])
--    if test "x$libpcap_version_1x" = "xno"; then
--        AC_MSG_RESULT(no)
-+    [daq_cv_libpcap_version_1x="yes"],
-+    [daq_cv_libpcap_version_1x="no"])])
-+    if test "x$daq_cv_libpcap_version_1x" = "xno"; then
-         echo
-         echo "    ERROR!  Libpcap library version >= $1  not found."
-         echo "    Get it from http://www.tcpdump.org"
-         echo
-         exit 1
--    else
--        AC_MSG_RESULT(yes)
-     fi
- ])
-
diff --git a/net-libs/daq/files/daq-2.0.2-parallel-grammar.patch b/net-libs/daq/files/daq-2.0.2-parallel-grammar.patch
deleted file mode 100644 (file)
index 42e0f93..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-https://bugs.gentoo.org/511892
-
-the scanner needs the generated header file, so make sure it's listed as a
-dependency.  else you see a failure:
-       $ cd sfbpf
-       $ make clean
-       $ make sf_scanner.lo
-       <missing tokdefs.h>
-we'd like to list it as a dep of the object, but automake can use generated
-file names, so it's not easy to list that.
-
-we can't have both of the outputs from grammar.y run the lex, otherwise we
-hit random parallel build failures:
-       $ cd sfbpf
-       $ make clean
-       $ make tokdefs.h sf_grammar.c -j
-       <run yacc twice & fail>
-
---- a/sfbpf/Makefile.am
-+++ b/sfbpf/Makefile.am
-@@ -43,14 +43,16 @@
- libsfbpf_la_LDFLAGS = -version-info 0:1:0 @XCCFLAGS@
- # use of $@ and $< here is a GNU idiom that borks BSD
--${builddir}/sf_scanner.c: ${srcdir}/scanner.l
-+${builddir}/sf_scanner.c: ${srcdir}/scanner.l ${builddir}/tokdefs.h
-       @rm -f ${builddir}/sf_scanner.c
-       ${srcdir}/runlex.sh $(V_LEX) -osf_scanner.c ${srcdir}/scanner.l
--${builddir}/tokdefs.h ${builddir}/sf_grammar.c: ${srcdir}/grammar.y
-+${builddir}/sf_grammar.c: ${srcdir}/grammar.y
-       @rm -f ${builddir}/sf_grammar.c ${builddir}/tokdefs.h
-       $(V_YACC) -d ${srcdir}/grammar.y
-       mv y.tab.c sf_grammar.c
-       mv y.tab.h tokdefs.h
-+${builddir}/tokdefs.h: ${builddir}/sf_grammar.c ; @true
-+
- CLEANFILES = ${builddir}/sf_scanner.c ${builddir}/sf_grammar.c ${builddir}/tokdefs.h ${builddir}/sf_scanner.h