dev-python/xapp: version bump to 2.0.1
authorOlivier Laurantin <olivier.laurantin@laposte.net>
Thu, 7 May 2020 19:38:41 +0000 (21:38 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 17 May 2020 16:41:51 +0000 (19:41 +0300)
Update to the latest upstream version
Add python 3.7 and 3.8 support

Closes: https://bugs.gentoo.org/721540
Signed-off-by: Olivier Laurantin <olivier.laurantin@laposte.net>
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/xapp/Manifest
dev-python/xapp/xapp-2.0.1.ebuild [new file with mode: 0644]

index 187bcc3700371d420bee0f78109960d0366b4587..14f3a1e81d59b3f821076320faeaed420b5d49a8 100644 (file)
@@ -1,2 +1,3 @@
 DIST xapp-1.0.1.tar.gz 12327 BLAKE2B a627a833adc8ca32823d4c04fd65ef3dedc2eedd031c3030105f1f2341fa17744fc81c976f4eaa1a238653392510d416692ce804ff5bcfe9ed12d9595245e8d3 SHA512 7dc4db03476f6972f6452800d2ea58d7f78d0bd5dd6719f2b49d1c2e3315c3fa09c294b1195bebd26357c30b4c43d7e5c01d160708dd17ee488b823344895e25
 DIST xapp-1.8.1.tar.gz 19665 BLAKE2B cdead609611396cb24a5f09a1ac47773569c1637b2730b00a545dbe8d3a03d183209a433bd7dfa3ed9bdd27389a6ec759072c899ab106180b839d22edd22b0c1 SHA512 8f20e15eda96f2cfab08c2b99fc20f2e3b686049ea23971b7fa8f8367eec019dce4199b332ae412bfb853de44ed5a1bb6573ea8ca052910f12ee5ced15bafc10
+DIST xapp-2.0.1.tar.gz 19839 BLAKE2B 692ef5a560681f415ab211b6f2870339dc80ca3ce90ac860637ce6765309b03f8ac41499ad5bcef51cde194b7cee2e3366abb3ddb5ee7e2212e3dac0da625387 SHA512 a529680ab2adbcd829ec224b7dafeb5f641afaabd51ac6cea154d1adf46772b0f2c58a78c6f136d3c6dde0b5d69a4e53a988f69d282af852ecf9ffa130ec1fe4
diff --git a/dev-python/xapp/xapp-2.0.1.ebuild b/dev-python/xapp/xapp-2.0.1.ebuild
new file mode 100644 (file)
index 0000000..8ab0a07
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for x11-libs/xapps"
+HOMEPAGE="https://github.com/linuxmint/python3-xapp"
+SRC_URI="https://github.com/linuxmint/python3-xapp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/xapps[introspection]"
+RDEPEND="${DEPEND}
+       dev-python/psutil[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/python3-xapp-${PV}"