games-board/polyglot: Fix compilation with musl libc.
authorUlrich Müller <ulm@gentoo.org>
Tue, 31 Mar 2020 10:26:47 +0000 (12:26 +0200)
committerUlrich Müller <ulm@gentoo.org>
Tue, 31 Mar 2020 10:27:25 +0000 (12:27 +0200)
Closes: https://bugs.gentoo.org/715560
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
games-board/polyglot/files/polyglot-1.4.70b-musl.patch [new file with mode: 0644]
games-board/polyglot/polyglot-1.4.70b-r3.ebuild

diff --git a/games-board/polyglot/files/polyglot-1.4.70b-musl.patch b/games-board/polyglot/files/polyglot-1.4.70b-musl.patch
new file mode 100644 (file)
index 0000000..5ccbdea
--- /dev/null
@@ -0,0 +1,30 @@
+Rename uint64_t to uint64 (same as in util.h) to avoid a name collision.
+https://bugs.gentoo.org/715560
+
+--- polyglot-1.4.70b-orig/pgheader.c
++++ polyglot-1.4.70b/pgheader.c
+@@ -49,12 +49,12 @@
+ #endif
+ #ifdef _MSC_VER
+-  typedef unsigned __int64 uint64_t;
++  typedef unsigned __int64 uint64;
+ #else
+-  typedef unsigned long long int uint64_t;
++  typedef unsigned long long int uint64;
+ #endif
+-static int int_from_file(FILE *f, int l, uint64_t *r){
++static int int_from_file(FILE *f, int l, uint64 *r){
+     int i,c;
+     for(i=0;i<l;i++){
+         c=fgetc(f);
+@@ -69,7 +69,7 @@
+ int pgheader_detect(const char *infile){
+     FILE *fin;
+-    uint64_t r0,r1,r2;
++    uint64 r0,r1,r2;
+     int i;
+     fin=fopen(infile,"rb");
index 23043395c452929989ccc296e9ae339bf168fce3..a69460e036c7fe3e7d632ccd7f082124d900c3dd 100644 (file)
@@ -12,5 +12,8 @@ LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 
-PATCHES=( "${FILESDIR}"/${P}-no-common.patch )
+PATCHES=(
+       "${FILESDIR}"/${P}-no-common.patch
+       "${FILESDIR}"/${P}-musl.patch
+)
 DOCS="AUTHORS ChangeLog TODO" # README* installed by build system