sci-mathematics/minisat: fix sed in header files
authorJeffrey Lin <jeffrey@icurse.nl>
Fri, 4 Jan 2019 03:37:59 +0000 (22:37 -0500)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 21 Oct 2019 14:32:09 +0000 (17:32 +0300)
Bug: https://bugs.gentoo.org/697562
Closes: https://bugs.gentoo.org/694982
Package-Manager: Portage-2.3.53, Repoman-2.3.12
Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sci-mathematics/minisat/minisat-2.2.0_p20130925-r1.ebuild [moved from sci-mathematics/minisat/minisat-2.2.0_p20130925.ebuild with 94% similarity]

similarity index 94%
rename from sci-mathematics/minisat/minisat-2.2.0_p20130925.ebuild
rename to sci-mathematics/minisat/minisat-2.2.0_p20130925-r1.ebuild
index 308bc18e8afde6e9bae8251b44338a62ce7f05bc..39e62e229e7d8f7d32fa6f30af22eff71c793e97 100644 (file)
@@ -36,7 +36,7 @@ src_prepare() {
        # Fix headers ( #include "minisat/..." -> #include <...> )
        while IFS="" read -d $'\0' -r file; do
                einfo Correcting header "$file"
-               sed -i -e 's:#include "minisat/\([^"]*\)":#include <\1>:g' "${file}" || die
+               sed -i -e 's:#include "minisat/\([^"]*\)":#include <minisat/\1>:g' "${file}" || die
        done < <(find minisat -name "*.h" -print0)
 }