net-firewall/iptables: revbump (no real changes)
authorMike Frysinger <vapier@gentoo.org>
Fri, 14 Aug 2015 09:10:41 +0000 (05:10 -0400)
committerMike Frysinger <vapier@gentoo.org>
Fri, 14 Aug 2015 09:28:25 +0000 (05:28 -0400)
net-firewall/iptables/files/iptables.init [new file with mode: 0755]
net-firewall/iptables/iptables-1.4.21-r2.ebuild [new file with mode: 0644]

diff --git a/net-firewall/iptables/files/iptables.init b/net-firewall/iptables/files/iptables.init
new file mode 100755 (executable)
index 0000000..440e840
--- /dev/null
@@ -0,0 +1,130 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+extra_commands="check save panic"
+extra_started_commands="reload"
+
+iptables_name=${SVCNAME}
+case ${iptables_name} in
+iptables|ip6tables) ;;
+*) iptables_name="iptables" ;;
+esac
+
+iptables_bin="/sbin/${iptables_name}"
+case ${iptables_name} in
+       iptables)  iptables_proc="/proc/net/ip_tables_names"
+                  iptables_save=${IPTABLES_SAVE};;
+       ip6tables) iptables_proc="/proc/net/ip6_tables_names"
+                  iptables_save=${IP6TABLES_SAVE};;
+esac
+
+depend() {
+       need localmount #434774
+       before net
+}
+
+set_table_policy() {
+       local chains table=$1 policy=$2
+       case ${table} in
+               nat)    chains="PREROUTING POSTROUTING OUTPUT";;
+               mangle) chains="PREROUTING INPUT FORWARD OUTPUT POSTROUTING";;
+               filter) chains="INPUT FORWARD OUTPUT";;
+               *)      chains="";;
+       esac
+       local chain
+       for chain in ${chains} ; do
+               ${iptables_bin} -t ${table} -P ${chain} ${policy}
+       done
+}
+
+checkkernel() {
+       if [ ! -e ${iptables_proc} ] ; then
+               eerror "Your kernel lacks ${iptables_name} support, please load"
+               eerror "appropriate modules and try again."
+               return 1
+       fi
+       return 0
+}
+checkconfig() {
+       if [ ! -f ${iptables_save} ] ; then
+               eerror "Not starting ${iptables_name}.  First create some rules then run:"
+               eerror "/etc/init.d/${iptables_name} save"
+               return 1
+       fi
+       return 0
+}
+
+start() {
+       checkconfig || return 1
+       ebegin "Loading ${iptables_name} state and starting firewall"
+       ${iptables_bin}-restore ${SAVE_RESTORE_OPTIONS} < "${iptables_save}"
+       eend $?
+}
+
+stop() {
+       if [ "${SAVE_ON_STOP}" = "yes" ] ; then
+               save || return 1
+       fi
+       checkkernel || return 1
+       ebegin "Stopping firewall"
+       local a
+       for a in $(cat ${iptables_proc}) ; do
+               set_table_policy $a ACCEPT
+
+               ${iptables_bin} -F -t $a
+               ${iptables_bin} -X -t $a
+       done
+       eend $?
+}
+
+reload() {
+       checkkernel || return 1
+       checkrules || return 1
+       ebegin "Flushing firewall"
+       local a
+       for a in $(cat ${iptables_proc}) ; do
+               ${iptables_bin} -F -t $a
+               ${iptables_bin} -X -t $a
+       done
+       eend $?
+
+       start
+}
+
+checkrules() {
+       ebegin "Checking rules"
+       ${iptables_bin}-restore --test ${SAVE_RESTORE_OPTIONS} < "${iptables_save}"
+       eend $?
+}
+
+check() {
+       # Short name for users of init.d script.
+       checkrules
+}
+
+save() {
+       ebegin "Saving ${iptables_name} state"
+       checkpath -q -d "$(dirname "${iptables_save}")"
+       checkpath -q -m 0600 -f "${iptables_save}"
+       ${iptables_bin}-save ${SAVE_RESTORE_OPTIONS} > "${iptables_save}"
+       eend $?
+}
+
+panic() {
+       checkkernel || return 1
+       if service_started ${iptables_name}; then
+               rc-service ${iptables_name} stop
+       fi
+
+       local a
+       ebegin "Dropping all packets"
+       for a in $(cat ${iptables_proc}) ; do
+               ${iptables_bin} -F -t $a
+               ${iptables_bin} -X -t $a
+
+               set_table_policy $a DROP
+       done
+       eend $?
+}
diff --git a/net-firewall/iptables/iptables-1.4.21-r2.ebuild b/net-firewall/iptables/iptables-1.4.21-r2.ebuild
new file mode 100644 (file)
index 0000000..c05cbf6
--- /dev/null
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+# Force users doing their own patches to install their own tools
+AUTOTOOLS_AUTO_DEPEND=no
+
+inherit eutils multilib systemd toolchain-funcs autotools
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.netfilter.org/projects/iptables/"
+SRC_URI="http://www.netfilter.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="conntrack ipv6 netlink static-libs"
+
+RDEPEND="
+       conntrack? ( net-libs/libnetfilter_conntrack )
+       netlink? ( net-libs/libnfnetlink )
+"
+DEPEND="${RDEPEND}
+       virtual/os-headers
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       # use the saner headers from the kernel
+       rm -f include/linux/{kernel,types}.h
+
+       # Only run autotools if user patched something
+       epatch_user && eautoreconf || elibtoolize
+}
+
+src_configure() {
+       # Some libs use $(AR) rather than libtool to build #444282
+       tc-export AR
+
+       sed -i \
+               -e "/nfnetlink=[01]/s:=[01]:=$(usex netlink 1 0):" \
+               -e "/nfconntrack=[01]/s:=[01]:=$(usex conntrack 1 0):" \
+               configure || die
+
+       econf \
+               --sbindir="${EPREFIX}/sbin" \
+               --libexecdir="${EPREFIX}/$(get_libdir)" \
+               --enable-devel \
+               --enable-shared \
+               $(use_enable static-libs static) \
+               $(use_enable ipv6)
+}
+
+src_compile() {
+       emake V=1
+}
+
+src_install() {
+       default
+       dodoc INCOMPATIBILITIES iptables/iptables.xslt
+
+       # all the iptables binaries are in /sbin, so might as well
+       # put these small files in with them
+       into /
+       dosbin iptables/iptables-apply
+       dosym iptables-apply /sbin/ip6tables-apply
+       doman iptables/iptables-apply.8
+
+       insinto /usr/include
+       doins include/iptables.h $(use ipv6 && echo include/ip6tables.h)
+       insinto /usr/include/iptables
+       doins include/iptables/internal.h
+
+       keepdir /var/lib/iptables
+       newinitd "${FILESDIR}"/${PN}.init iptables
+       newconfd "${FILESDIR}"/${PN}-1.4.13.confd iptables
+       if use ipv6 ; then
+               keepdir /var/lib/ip6tables
+               newinitd "${FILESDIR}"/iptables.init ip6tables
+               newconfd "${FILESDIR}"/ip6tables-1.4.13.confd ip6tables
+       fi
+
+       systemd_dounit "${FILESDIR}"/systemd/iptables{,-{re,}store}.service
+       if use ipv6 ; then
+               systemd_dounit "${FILESDIR}"/systemd/ip6tables{,-{re,}store}.service
+       fi
+
+       # Move important libs to /lib
+       gen_usr_ldscript -a ip{4,6}tc iptc xtables
+
+       prune_libtool_files
+}