sys-apps/nix: bump up to 2.3.1
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 10 Oct 2019 22:34:40 +0000 (23:34 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 10 Oct 2019 22:34:40 +0000 (23:34 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-apps/nix/Manifest
sys-apps/nix/nix-2.3.1.ebuild [new file with mode: 0644]

index 61c8f635ed0212400f448e39052f323daa64df3d..ea73107703054cc23f72c9bb0625ca9377e961c1 100644 (file)
@@ -1,2 +1,3 @@
 DIST nix-2.2.2.tar.xz 818408 BLAKE2B f13bf79596d6292bea9897805421b388241d670f2b36bc13882f610901a9bb9aa1dc977d7a7d9314139791f20be38ca85becf5c4e863b22fc0b39503a7a4a079 SHA512 c8b1d5f246c53f13cfa25cba0d0721a2628329c10f67fcccbd9a55279cf475170a105156559d0a62638822a8e972f85e8a58769444d51f94ba15e2af7f90e220
+DIST nix-2.3.1.tar.xz 844608 BLAKE2B a5c8e97aad8bd8dea644f8aa04665cc078a69c7203891c469900ca1b1450a5714281209235bcaedbc6f3f128e0c11aff41850f3b0815ef657e13de3364ff0188 SHA512 791c377082cf8dd17a24d927caa4127eeb20bd03d479424861928437eb352cb4650beb7f36d92d85ce6a7404f4fbfc5a36a342d09061e88dbafd1b51463eb15f
 DIST nix-2.3.tar.xz 844640 BLAKE2B 09707ae6c50c118375cdf2469a3ca19fbd940454bb80b7bccd74824deb3e370107acca99d7bf69bc93a168521a8d4928e3ac73fcfe1eeb53801d8e5f18574096 SHA512 45cb0c195f220a57cef80ad79def5e65b85588a2fc390f9b5e2ac4309698cc3065a23ee4f836913b642348afb1ee625072538bfedb5b26f9626344bbe784b425
diff --git a/sys-apps/nix/nix-2.3.1.ebuild b/sys-apps/nix/nix-2.3.1.ebuild
new file mode 100644 (file)
index 0000000..bbfe27e
--- /dev/null
@@ -0,0 +1,137 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic readme.gentoo-r1 user
+
+DESCRIPTION="A purely functional package manager"
+HOMEPAGE="https://nixos.org/nix"
+
+SRC_URI="http://nixos.org/releases/${PN}/${P}/${P}.tar.xz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+etc-profile +gc doc s3 +sodium"
+
+# sys-apps/busybox is needed for sandbox mount of /bin/sh
+RDEPEND="
+       app-arch/brotli
+       app-arch/bzip2
+       app-arch/xz-utils
+       sys-apps/busybox[static]
+       dev-db/sqlite
+       dev-libs/editline:0=
+       dev-libs/openssl:0=
+       >=dev-libs/boost-1.66:0=[context]
+       net-misc/curl
+       sys-libs/libseccomp
+       sys-libs/zlib
+       gc? ( dev-libs/boehm-gc[cxx] )
+       doc? ( dev-libs/libxml2
+               dev-libs/libxslt
+               app-text/docbook-xsl-stylesheets
+       )
+       s3? ( dev-libs/aws-sdk-cpp )
+       sodium? ( dev-libs/libsodium:0= )
+"
+DEPEND="${RDEPEND}
+       >=sys-devel/bison-2.6
+       >=sys-devel/flex-2.5.35
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.3-libpaths.patch
+       "${FILESDIR}"/${PN}-2.3-bootstrap.patch
+)
+
+DISABLE_AUTOFORMATTING=yes
+DOC_CONTENTS=" Quick start user guide on Gentoo:
+
+[as root] enable nix-daemon service:
+       [systemd] # systemctl enable nix-daemon
+       [openrc]  # rc-update add nix-daemon
+[as a user] relogin to get environment and profile update
+[as a user] fetch nixpkgs update:
+       \$ nix-channel --update
+[as a user] install nix packages:
+       \$ nix-env -i mc
+[as a user] configure environment:
+       Somewhere in .bash_profile you might want to set
+       LOCALE_ARCHIVE=\$HOME/.nix-profile/lib/locale/locale-archive
+       but please read https://github.com/NixOS/nixpkgs/issues/21820
+
+Next steps:
+       nix package manager user manual: http://nixos.org/nix/manual/
+"
+
+pkg_setup() {
+       enewgroup nixbld
+       for i in {1..10}; do
+               # we list 'nixbld' twice to
+               # both assign a primary group for user
+               # and add a user to /etc/group
+               enewuser nixbld${i} -1 -1 /var/empty nixbld,nixbld
+       done
+}
+
+src_prepare() {
+       default
+
+       eautoreconf
+}
+
+src_configure() {
+       if ! use s3; then
+               # Disable automagic depend: bug #670256
+               export ac_cv_header_aws_s3_S3Client_h=no
+       fi
+       econf \
+               --localstatedir="${EPREFIX}"/nix/var \
+               $(use_enable gc) \
+               --with-sandbox-shell=/bin/busybox
+}
+
+src_compile() {
+       emake V=1
+}
+
+src_install() {
+       # TODO: emacs highlighter
+       default
+
+       readme.gentoo_create_doc
+
+       # here we use an eager variant of something that
+       # is lazily done by nix-daemon and root nix-env
+
+       # TODO: will need a tweak for prefix
+       keepdir             /nix/store
+       fowners root:nixbld /nix/store
+       fperms 1775         /nix/store
+
+       keepdir             /nix/var/nix/channel-cache
+       fperms 0777         /nix/var/nix/channel-cache
+
+       keepdir             /nix/var/nix/profiles/per-user
+       fperms 1777         /nix/var/nix/profiles/per-user
+
+       # setup directories nix-daemon: /etc/profile.d/nix-daemon.sh
+       keepdir             /nix/var/nix/gcroots/per-user
+       fperms 1777         /nix/var/nix/gcroots/per-user
+
+       newinitd "${FILESDIR}"/nix-daemon.initd nix-daemon
+
+       if ! use etc-profile; then
+               rm "${ED}"/etc/profile.d/nix.sh || die
+               rm "${ED}"/etc/profile.d/nix-daemon.sh || die
+       fi
+}
+
+pkg_postinst() {
+       if ! use etc-profile; then
+               ewarn "${EROOT}/etc/profile.d/nix.sh was removed (due to USE=-etc-profile)."
+       fi
+
+       readme.gentoo_print_elog
+}