net-misc/ntp: Add patch to fix build with gcc-4.9
authorPatrick McLean <chutzpah@gentoo.org>
Wed, 22 Mar 2017 18:52:01 +0000 (11:52 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 22 Mar 2017 18:52:01 +0000 (11:52 -0700)
Upstream somehow dropped -fPIC on the ntpq libraries, this breaks build
with gcc-4.9 (current stable). This adds the calculated NTP_HARD_CFLAGS
to the CFLAGS for ntpq, which includes -fPIC if configure decides it's
needed.

Package-Manager: Portage-2.3.5, Repoman-2.3.2

net-misc/ntp/files/ntp-4.2.8_p10-ntpq-fpic.patch [new file with mode: 0644]
net-misc/ntp/ntp-4.2.8_p10.ebuild

diff --git a/net-misc/ntp/files/ntp-4.2.8_p10-ntpq-fpic.patch b/net-misc/ntp/files/ntp-4.2.8_p10-ntpq-fpic.patch
new file mode 100644 (file)
index 0000000..dcf75d2
--- /dev/null
@@ -0,0 +1,11 @@
+--- ntp-4.2.8p10.orig/ntpq/Makefile.am 2017-03-21 06:04:21.000000000 -0700
++++ ntp-4.2.8p10/ntpq/Makefile.am      2017-03-22 11:45:48.946630492 -0700
+@@ -23,7 +23,7 @@
+ ntpq_LDADD += $(LDADD_NTP)
+ noinst_HEADERS=       ntpq.h
+ noinst_LIBRARIES=     libntpq.a
+-libntpq_a_CFLAGS=     -DNO_MAIN_ALLOWED -DBUILD_AS_LIB
++libntpq_a_CFLAGS=     $(NTP_HARD_CFLAGS) -DNO_MAIN_ALLOWED -DBUILD_AS_LIB
+ CLEANFILES=
+ DISTCLEANFILES=       .version version.c config.log $(man_MANS)
+ ETAGS_ARGS=   Makefile.am
index 89b01a6058f35f4f6528afb6960a10443c95bb97..31948a88e5bf4df86c7ea0f024b5f744f9998904 100644 (file)
@@ -39,6 +39,7 @@ S=${WORKDIR}/${MY_P}
 PATCHES=(
        "${FILESDIR}"/${PN}-4.2.8-ipc-caps.patch #533966
        "${FILESDIR}"/${PN}-4.2.8-sntp-test-pthreads.patch #563922
+       "${FILESDIR}"/${PN}-4.2.8_p10-ntpq-fpic.patch
 )
 
 pkg_setup() {