dev-python/lit: Switch live to monorepo
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 08:34:37 +0000 (09:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 13:15:44 +0000 (14:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/lit/lit-10.0.0.9999.ebuild
dev-python/lit/lit-9.0.1.9999.ebuild

index 32320b7920e1b267090e0293501c94344f6e77e7..05acb219e32931f1d06afb1c566996ed8a266544 100644 (file)
@@ -9,10 +9,8 @@ inherit distutils-r1 git-r3 multiprocessing
 DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-S=${WORKDIR}/${P}/utils/lit
-
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
-       https://github.com/llvm-mirror/llvm.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/llvm/utils/lit
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -31,7 +29,7 @@ BDEPEND="
 
 src_unpack() {
        git-r3_fetch
-       git-r3_checkout '' '' '' utils/lit
+       git-r3_checkout '' '' '' llvm/utils/lit
 }
 
 python_test() {
index c9fb8cb2815475242006c20e37540f3dfacdde99..ca1cce6c00b2391269df40102cc53a3628712943 100644 (file)
@@ -9,11 +9,9 @@ inherit distutils-r1 git-r3 multiprocessing
 DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-S=${WORKDIR}/${P}/utils/lit
-
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
-       https://github.com/llvm-mirror/llvm.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/llvm/utils/lit
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -32,7 +30,7 @@ BDEPEND="
 
 src_unpack() {
        git-r3_fetch
-       git-r3_checkout '' '' '' utils/lit
+       git-r3_checkout '' '' '' llvm/utils/lit
 }
 
 python_test() {