app-eselect/eselect-postgresql: Bump to 2.4
authorAaron W. Swenson <titanofold@gentoo.org>
Wed, 7 Nov 2018 11:41:21 +0000 (06:41 -0500)
committerAaron W. Swenson <titanofold@gentoo.org>
Wed, 7 Nov 2018 11:41:33 +0000 (06:41 -0500)
In some conditions, ln will follow symlinks it isn’t supposed to. Add
the -n switch to keep that from happening.

Bug: https://bugs.gentoo.org/662810
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Aaron Swenson <titanofold@gentoo.org>
app-eselect/eselect-postgresql/Manifest
app-eselect/eselect-postgresql/eselect-postgresql-2.4.ebuild [new file with mode: 0644]

index a3927678f4bcdbfa01a60619f4ae01623683c3de..7b1669a1842330de0cc9be9e187b03ad8e06a2e9 100644 (file)
@@ -1 +1,2 @@
 DIST eselect-postgresql-2.3.tbz2 4526 BLAKE2B 226f2be462d54d835cc884f6b2c33e0f84d4500e19251fb6794929901ec033e0fa457d8606e36ada462d538674110ba8aab901ca9f86dccd52ccf9c860ba5ce1 SHA512 d7f87aa3e21c5e35f3a6879bdfb9404a2884f761463f77952f21c522b1605f191385ba7b4758548b121ad7eb56d395163e0d6bba57df446be515e6d7163635b4
+DIST eselect-postgresql-2.4.tbz2 4518 BLAKE2B 726c59f0511b2e27493cceb9b9a7b3c58e7d7bb0cba2fef705eef9190ef384c3116c42079566d8761192b9c288ef57c550f659a0398ba90fa069f6be335550ff SHA512 4eed12905e97a45420a299cc9232be62a1ac88257a047d9d16ef7d8c8a0e0ddbd4177415797defe352cc82cd87b7777907a51a8cadfdb28064faa78a28e0099d
diff --git a/app-eselect/eselect-postgresql/eselect-postgresql-2.4.ebuild b/app-eselect/eselect-postgresql/eselect-postgresql-2.4.ebuild
new file mode 100644 (file)
index 0000000..d5d878e
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Utility to select the default PostgreSQL slot"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://dev.gentoo.org/~titanofold/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RDEPEND="app-admin/eselect"
+
+# All dev-db/postgresql ebuilds from 10.0 on are well supported. Earlier
+# ebuilds may present some quality of life issues.
+PDEPEND="
+       !<dev-db/postgresql-9.6.2-r1:9.6
+       !<dev-db/postgresql-9.5.6-r1:9.5
+       !<dev-db/postgresql-9.4.11-r1:9.4
+       !<dev-db/postgresql-9.3.16-r1:9.3
+       !<dev-db/postgresql-9.2.20-r1
+"
+
+src_install() {
+       insinto /usr/share/eselect/modules
+       doins postgresql.eselect
+
+       dosym eselect /usr/bin/postgresql-config
+}
+
+pkg_postinst() {
+       postgresql-config update
+}