dev-python/hypothesis: Remove redundant version
authorMichał Górny <mgorny@gentoo.org>
Tue, 14 Jan 2020 03:35:50 +0000 (04:35 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 14 Jan 2020 03:53:23 +0000 (04:53 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/hypothesis/Manifest
dev-python/hypothesis/hypothesis-5.1.3.ebuild [deleted file]

index 191ed140a66acfa201dc62566192ebb55a192a38..95a9dd19cb0c0a157bd0c2f56fdb2d78713a8d2e 100644 (file)
@@ -3,5 +3,4 @@ DIST hypothesis-python-4.47.5.tar.gz 6805022 BLAKE2B 737a558c794f3ac428bef4b3885
 DIST hypothesis-python-4.50.8.tar.gz 6814518 BLAKE2B f2c39cae3708fe88d1854cda97633ba420c32fda38093bb852ef45929762cade0f7f0d1ef696ff96f7ebe7460e8bf53f63de9c959bbbd9e8ec162196d307aac0 SHA512 8c77439fd029e2380afbc059d2edf977414997ba81ecdfde14dfe9dbe9515a92e701751d13879c6b879271f817e01926c2dc66945ae76eb141818da1775bc545
 DIST hypothesis-python-4.55.4.tar.gz 9004357 BLAKE2B 93fe51581f044cf5f416d9b74b82ce2f9b42e7391beae8f67debdf50494e662f07bf109274d4e29fcf3a1c1c944597cde2a4ff9e7ca65a48f1244c3205f365af SHA512 91d7d2cda32fd40d5368fdd1e60b990b8307573782d822113b6817a5c0b670610693a2f2b013f828913549946fa3dc15f45303bf7d3226bdc1e4527bc18981fb
 DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a109791d3acf3821852f8e170991b0be5b069f166e16bdacf7a82fbe49bd9db5188315cdec7cdb4592647571233949ec5732991 SHA512 28622ce8a1d89d09df65f3fbf7e92a1ad98dac140ab646fe11fcb15e6aa9a9672eb51d459f984384d92b819f902de911b06cec2542582d529dd556d2f99ed952
-DIST hypothesis-python-5.1.3.tar.gz 8989332 BLAKE2B a86409b0620b3821aae8f23f0473be08ed1152140f05c2ebcb3f226cc133fdbbb617856c768bc6034bcf25e6603e9e72b1b885df116fb9dfce7164018792fb99 SHA512 dd854158c1e903562c7aa101fe7810837816102b1f5dd840ec3d5df9abd9c1463d05adab79ef428749ea2a5d1a425150971d23ae3259b71baf0e0e8a8a9a3bb8
 DIST hypothesis-python-5.1.4.tar.gz 8989696 BLAKE2B 9d85cb1473654e36a235a07d2390fc967d6d7f2944e5294dedbca15ddb3c49901b04e9277ee80ff7591aa2b81ea0e2d537051f96b685900aefab5db70d135ac6 SHA512 25d0112f7b7a13221b8b68d553f4085344f1e8681c8795fac0bcfd714400a828539298d2919d3e638979eadd5daa65ef7ee8b0b946df076145e59c8bb7058a64
diff --git a/dev-python/hypothesis/hypothesis-5.1.3.ebuild b/dev-python/hypothesis/hypothesis-5.1.3.ebuild
deleted file mode 100644 (file)
index 97b51c5..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A library for property based testing"
-HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
-SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
-S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
-       >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pexpect[${PYTHON_USEDEP}]
-               >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
-               !!<dev-python/typing-3.7.4.1
-       )
-"
-
-src_prepare() {
-       # avoid pytest-xdist dep for one test
-       sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
-               tests/pytest/test_statistics.py || die
-       distutils-r1_src_prepare
-}
-
-python_test() {
-       pytest -vv tests/cover tests/pytest tests/quality ||
-               die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
-       optfeature "datetime support" dev-python/pytz
-       optfeature "dateutil support" dev-python/python-dateutil
-       optfeature "numpy support" dev-python/numpy
-       optfeature "django support" dev-python/django dev-python/pytz
-       optfeature "pandas support" dev-python/pandas
-       optfeature "pytest support" dev-python/pytest
-}