app-misc/lirc: 0.9.4d version bump
authorCraig Andrews <candrews@integralblue.com>
Fri, 3 Mar 2017 22:11:25 +0000 (17:11 -0500)
committerMichael Palimaka <kensington@gentoo.org>
Sat, 4 Mar 2017 00:55:40 +0000 (11:55 +1100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2

app-misc/lirc/Manifest
app-misc/lirc/lirc-0.9.4d.ebuild [new file with mode: 0644]

index 7cb5196abee26991122d2c21fd4bb23a949e8439..79f643bb7fd0dfba2495c4dca2736afed8267fc2 100644 (file)
@@ -1,3 +1,4 @@
 DIST lirc-0.9.0.tar.bz2 857286 SHA256 6323afae6ad498d4369675f77ec3dbb680fe661bea586aa296e67f2e2daba4ff SHA512 e91534c63e6065bd7da3b15e1676edf1672b8beb21864a6825df86247d7d165bf2dee6f8191732933e24e42a406e46afc55559948e4061eed2de7b08fac13431 WHIRLPOOL 0a1c00b07898aa7a5d78865fb73c6d26c6331dd0a4945773a801d29e40298b365eb58cae113a95fcf73be678a24ac082ad0868e8051303d732882fb82a859a7b
 DIST lirc-0.9.4a.tar.bz2 2292119 SHA256 386086a74c7d12e7e8f26f7dbc8f40d20b9968c9ad2a42599483a51dd2da03ba SHA512 16be0ac5dd9b07d717ceba63cdc38c0db4a2bdcfc373ca6346d7cd4ab2cd2973aa7585d10b045fcaea952a3aabf7617c564ccb8268db6c62b172683a4b2cc188 WHIRLPOOL 93431c43d2dd31081e97113e2d49134de7feb29be53508900b3360408f7a099becf169fcebd0f6fc196280c594dc83d1299617ee54b65452828492db9bcd09ad
 DIST lirc-0.9.4c.tar.bz2 2311300 SHA256 8974fe5dc8eaa717daab6785d2aefeec27615f01ec24b96d31e3381b2f70726a SHA512 0a0d0e025b87a55ec919c92824d8288bfaf35cfebae0ee97d86e344109f584baa72a2eff6d24fbc526900671d6092e0eebef8d1566559b0d153e122e3127c0cb WHIRLPOOL a614fc10b0e40831e81c558439ea528ae0628d64e55b272b9b5a97cb93cba2b8759062a5258c732fa97c2be7966226c3aca2efe2de84aad1f62211146d202efc
+DIST lirc-0.9.4d.tar.bz2 2489704 SHA256 c68f18c35b489b865c0a741d119b136e8702191538cd3551b977a7af6c4e41ab SHA512 fb3892e12fbe5277e04c451694f1ea4ed45cc424d66ea57b11c4ac4760afa7df4b37897f380b4ade464a82523a0cee336f216d2009ea9431333fd7ca74a8336c WHIRLPOOL c5b1d803d4bb8e269ae96a69f351b304298fd6577fd1d8871f024f1b118e71f392945153cb397a840c5f1b71d1fa475db1bb04d381c18c8580c9e148238cfeea
diff --git a/app-misc/lirc/lirc-0.9.4d.ebuild b/app-misc/lirc/lirc-0.9.4d.ebuild
new file mode 100644 (file)
index 0000000..0d55080
--- /dev/null
@@ -0,0 +1,150 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit eutils flag-o-matic python-single-r1 systemd xdg-utils
+
+DESCRIPTION="decode and send infra-red signals of many commonly used remote controls"
+HOMEPAGE="http://www.lirc.org/"
+
+LIRC_DRIVER_DEVICE="/dev/lirc0"
+
+MY_P=${PN}-${PV/_/}
+
+if [[ "${PV/_pre/}" = "${PV}" ]]; then
+       SRC_URI="mirror://sourceforge/lirc/${MY_P}.tar.bz2"
+else
+       SRC_URI="http://www.lirc.org/software/snapshots/${MY_P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="audio doc ftdi gtk inputlirc static-libs systemd usb X"
+
+REQUIRED_USE="
+       ${PYTHON_REQUIRED_USE}
+       gtk? ( X )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+       ${PYTHON_DEPS}
+       audio? (
+               >media-libs/portaudio-18
+               media-libs/alsa-lib
+       )
+       dev-python/pyyaml[${PYTHON_USEDEP}]
+       ftdi? ( dev-embedded/libftdi:0 )
+       systemd? ( sys-apps/systemd )
+       usb? ( virtual/libusb:0 )
+       X? (
+               x11-libs/libICE
+               x11-libs/libSM
+               x11-libs/libX11
+       )
+"
+
+DEPEND="
+       ${COMMON_DEPEND}
+       dev-libs/libxslt
+       doc? ( app-doc/doxygen )
+       sys-apps/kmod
+       sys-kernel/linux-headers
+"
+
+RDEPEND="
+       ${COMMON_DEPEND}
+       gtk? (
+               x11-libs/vte[introspection]
+               dev-python/pygobject[${PYTHON_USEDEP}]
+       )
+       inputlirc? ( app-misc/inputlircd )
+"
+
+PATCHES=(
+       # https://bugs.gentoo.org/show_bug.cgi?id=589246 https://sourceforge.net/p/lirc/tickets/214/
+       "${FILESDIR}"/lirc-0.9.4-doc-path-fix.patch
+)
+
+src_configure() {
+       xdg_environment_reset
+       econf \
+               --localstatedir="${EPREFIX}/var" \
+               $(use_enable static-libs static) \
+               $(use_with X x)
+}
+
+src_install() {
+       default
+
+       if use !gtk ; then
+               # lirc-setup requires gtk
+               rm "${ED%/}"/usr/bin/lirc-setup || die
+       fi
+
+       newinitd "${FILESDIR}"/lircd-0.8.6-r2 lircd
+       newinitd "${FILESDIR}"/lircmd-0.9.4a-r2 lircmd
+       newconfd "${FILESDIR}"/lircd.conf.4 lircd
+       newconfd "${FILESDIR}"/lircmd.conf lircmd
+
+       insinto /etc/modprobe.d/
+       newins "${FILESDIR}"/modprobed.lirc lirc.conf
+
+       newinitd "${FILESDIR}"/irexec-initd-0.9.4a-r2 irexec
+       newconfd "${FILESDIR}"/irexec-confd irexec
+
+       keepdir /etc/lirc
+       if [[ -e "${ED%/}"/etc/lirc/lircd.conf ]]; then
+               newdoc "${ED%/}"/etc/lirc/lircd.conf lircd.conf.example
+       fi
+
+       find "${ED}" -name '*.la' -delete || die
+
+       # Avoid QA notice
+       rm -d "${ED%/}"/var/run/lirc || die
+       rm -d "${ED%/}"/var/run || die
+}
+
+pkg_preinst() {
+       local dir="${EROOT%/}/etc/modprobe.d"
+       if [[ -a "${dir}"/lirc && ! -a "${dir}"/lirc.conf ]]; then
+               elog "Renaming ${dir}/lirc to lirc.conf"
+               mv -f "${dir}/lirc" "${dir}/lirc.conf" || die
+       fi
+
+       # copy the first file that can be found
+       if [[ -f "${EROOT%/}"/etc/lirc/lircd.conf ]]; then
+               cp "${EROOT%/}"/etc/lirc/lircd.conf "${T}"/lircd.conf || die
+       elif [[ -f "${EROOT%/}"/etc/lircd.conf ]]; then
+               cp "${EROOT%/}"/etc/lircd.conf "${T}"/lircd.conf || die
+               MOVE_OLD_LIRCD_CONF=1
+       elif [[ -f "${ED%/}"/etc/lirc/lircd.conf ]]; then
+               cp "${ED%/}"/etc/lirc/lircd.conf "${T}"/lircd.conf || die
+       fi
+
+       # stop portage from touching the config file
+       if [[ -e "${ED%/}"/etc/lirc/lircd.conf ]]; then
+               rm -f "${ED%/}"/etc/lirc/lircd.conf || die
+       fi
+}
+
+pkg_postinst() {
+       # copy config file to new location
+       # without portage knowing about it
+       # so it will not delete it on unmerge or ever touch it again
+       if [[ -e "${T}"/lircd.conf ]]; then
+               cp "${T}"/lircd.conf "${EROOT%/}"/etc/lirc/lircd.conf || die
+               if [[ "$MOVE_OLD_LIRCD_CONF" = "1" ]]; then
+                       elog "Moved /etc/lircd.conf to /etc/lirc/lircd.conf"
+                       rm -f "${EROOT%/}"/etc/lircd.conf || die
+               fi
+       fi
+
+       einfo "The new default location for lircd.conf is inside of"
+       einfo "${EROOT%/}/etc/lirc/ directory"
+}