dev-python/elasticsearch-py: add missing die to 7.5.1
authorJoonas Niilola <juippis@gentoo.org>
Fri, 24 Jan 2020 06:39:10 +0000 (08:39 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 24 Jan 2020 06:54:34 +0000 (08:54 +0200)
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/elasticsearch-py/elasticsearch-py-7.5.1.ebuild

index 6d0fdfff8419b8c6ae7e562ab4d6fee9ffa8e035..df9f5afd87073505535dfb21e33c01bc5f0b6ee3 100644 (file)
@@ -55,7 +55,7 @@ python_test() {
        local es_instance="gentoo-es-py-test"
        local es_log="${es}/logs/${es_instance}.log"
        local pid="${es}/elasticsearch.pid"
-       export JAVA_HOME=$(java-config -g JAVA_HOME)
+       export JAVA_HOME=$(java-config -g JAVA_HOME || die)
 
        # run Elasticsearch instance on custom port
        sed -i "s/#http.port: 9200/http.port: ${es_port}/g; \