New release (non-beta)
authorOlivier Crête <tester@gentoo.org>
Wed, 17 Jan 2007 14:27:39 +0000 (14:27 +0000)
committerOlivier Crête <tester@gentoo.org>
Wed, 17 Jan 2007 14:27:39 +0000 (14:27 +0000)
Package-Manager: portage-2.1.1-r2

net-www/netscape-flash/files/digest-netscape-flash-9.0.31.0 [new file with mode: 0644]
net-www/netscape-flash/netscape-flash-9.0.31.0.ebuild [new file with mode: 0644]

diff --git a/net-www/netscape-flash/files/digest-netscape-flash-9.0.31.0 b/net-www/netscape-flash/files/digest-netscape-flash-9.0.31.0
new file mode 100644 (file)
index 0000000..93177ed
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 76b38231a68995935185aa42dfda9db7 install_flash_player_9_linux.tar.gz 2609703
+RMD160 bad57e9349c5b1bb0b12a7dee7dea8f24af2f764 install_flash_player_9_linux.tar.gz 2609703
+SHA256 e31b971be7f98ea7eff67b2783ae20170c4d9f595b43ae5b59f98385a2b0c978 install_flash_player_9_linux.tar.gz 2609703
diff --git a/net-www/netscape-flash/netscape-flash-9.0.31.0.ebuild b/net-www/netscape-flash/netscape-flash-9.0.31.0.ebuild
new file mode 100644 (file)
index 0000000..fe50f51
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-9.0.31.0.ebuild,v 1.1 2007/01/17 14:27:39 tester Exp $
+
+inherit nsplugins
+
+DESCRIPTION="Adobe Flash Player"
+SRC_URI="http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz"
+HOMEPAGE="http://www.adobe.com/"
+IUSE=""
+SLOT="0"
+
+KEYWORDS="~amd64 -ppc -sparc ~x86"
+LICENSE="AdobeFlash-9.0.31.0"
+S=${WORKDIR}/install_flash_player_9_linux
+RESTRICT="nostrip nomirror"
+
+DEPEND="!net-www/gplflash
+       amd64? ( app-emulation/emul-linux-x86-baselibs
+                       app-emulation/emul-linux-x86-gtklibs
+                       app-emulation/emul-linux-x86-soundlibs
+                        app-emulation/emul-linux-x86-xlibs )
+       x86? ( x11-libs/libXext
+               x11-libs/libX11
+               x11-libs/libXt
+               =x11-libs/gtk+-2*
+               media-libs/freetype
+               media-libs/fontconfig )"
+
+
+pkg_setup() {
+       # This is a binary x86 package => ABI=x86
+       # Please keep this in future versions
+       # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+       has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+
+       exeinto /opt/netscape/plugins
+       doexe libflashplayer.so
+       insinto /opt/netscape/plugins
+       doins flashplayer.xpt
+
+       inst_plugin /opt/netscape/plugins/libflashplayer.so
+       inst_plugin /opt/netscape/plugins/flashplayer.xpt
+
+       dodoc Readme.txt
+}