dev-python/pkginfo-1.5.0.1: Version bump, add py38
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 4 Dec 2019 22:23:55 +0000 (14:23 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 4 Dec 2019 22:23:55 +0000 (14:23 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/pkginfo/Manifest
dev-python/pkginfo/pkginfo-1.5.0.1.ebuild [new file with mode: 0644]

index 0968a82b87f1d7b162ac716307454e48a54baf12..7bd69642b0344dab97eebf3c9f34cc6d81303627 100644 (file)
@@ -1,2 +1,3 @@
 DIST pkginfo-1.2.1.tar.gz 31072 BLAKE2B 57ce5f6147b97af513dfdc6137180e5561822096cdbd21b673c49522384622c58f9eba8c65f24b54bc1e76dc0c6feede5d43e8aac945d94ffe79ea220e830470 SHA512 8a530a164befdcbc6f1f550e106880e14e9d2c762a5e1055f926ccf0228d9e2312f11598454ef015e97dccb78ac7aeb7309f34279590cd318c19c2bd9a29ed2a
 DIST pkginfo-1.4.2.tar.gz 33539 BLAKE2B d3cfc6bf7a9e748902b1f63434c745d8abf4e144c0a2b5d7a90236bfc2ce7f94922b0e08e5a08b13ba2025159bd90fecee25d9abdb283e7d52de0d34386aba59 SHA512 536628a2a2472e999695a115449a76f971453aea7ac3a08f10d9b08dfdf4a7b8e67c6010c6f18d300472a6afc8dff33331c955cc2f7bdb357504cd6a36390da3
+DIST pkginfo-1.5.0.1.tar.gz 34496 BLAKE2B b5a60e3fe2408283afbdebf8efa709b7b1c96b82ddc76b3fbc4d58d544c2170de1434525fe2e324af9864332c6570885b05a3d8ec2c248fbff20984d2ee80a94 SHA512 319bb403970affd5a4222dfdb3d17738630d1350ea84e51ad1bebc6c8c72e0dcfd69a4eaf5e7bd156b8e605d806357922c05cc994dcafb01b7a33c617b2df447
diff --git a/dev-python/pkginfo/pkginfo-1.5.0.1.ebuild b/dev-python/pkginfo/pkginfo-1.5.0.1.ebuild
new file mode 100644 (file)
index 0000000..6716367
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="https://pypi.org/project/pkginfo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests nose
+distutils_enable_sphinx docs
+
+python_test() {
+       distutils_install_for_testing
+
+       pushd "${TEST_DIR}/lib" >/dev/null || die
+       nosetests -v || die "Tests fail with ${EPYTHON}"
+       popd >/dev/null || die
+}