sys-apps/coreutils: fix sandbox-env-test.patch
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 30 Apr 2020 01:04:14 +0000 (03:04 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 30 Apr 2020 01:04:59 +0000 (03:04 +0200)
I extended PR and excluded more tests. However, I overlooked
that one of these tests aren't present in 8.31.

This commit will fix previous commit a48e67d33ef6edd58b2cd6111884dbb4fdef7491
and provide two versions of the patch.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-apps/coreutils/coreutils-8.32-r1.ebuild
sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch
sys-apps/coreutils/files/coreutils-8.32-sandbox-env-test.patch [new file with mode: 0644]

index 3eac2b76aae2bc8c6afb59d0095ad708aa8c3b05..153e7d36ac9e9e774001b9826ae7dd7d6b17ca3e 100644 (file)
@@ -71,7 +71,7 @@ src_prepare() {
 
        if ! use vanilla ; then
                PATCHES+=( "${WORKDIR}"/patch )
-               PATCHES+=( "${FILESDIR}"/${PN}-8.31-sandbox-env-test.patch )
+               PATCHES+=( "${FILESDIR}"/${PN}-8.32-sandbox-env-test.patch )
        fi
 
        default
index 40b1554d948ab40c98c67e004e97adbc6a62e25e..f81ea13776b3585667f538f2448aed26b2b467f0 100644 (file)
@@ -12,18 +12,6 @@ Skip tests known to fail when running under Gentoo sandbox.
  print_ver_ du
  
  require_perl_
---- a/tests/ls/removed-directory.sh
-+++ b/tests/ls/removed-directory.sh
-@@ -19,6 +19,9 @@
- # along with this program.  If not, see <https://www.gnu.org/licenses/>.
- . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
-+# Avoid #413621 until #548250 is resolved
-+test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
-+
- print_ver_ ls
- case $host_triplet in
 --- a/tests/ls/stat-free-symlinks.sh
 +++ b/tests/ls/stat-free-symlinks.sh
 @@ -17,6 +17,9 @@
diff --git a/sys-apps/coreutils/files/coreutils-8.32-sandbox-env-test.patch b/sys-apps/coreutils/files/coreutils-8.32-sandbox-env-test.patch
new file mode 100644 (file)
index 0000000..40b1554
--- /dev/null
@@ -0,0 +1,64 @@
+Skip tests known to fail when running under Gentoo sandbox.
+
+--- a/tests/du/long-from-unreadable.sh
++++ b/tests/du/long-from-unreadable.sh
+@@ -29,6 +29,9 @@
+ # unnecessarily to using FTS_NOCHDIR mode in this corner case.
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
++# Avoid #413621 until #548250 is resolved
++test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
++
+ print_ver_ du
+ require_perl_
+--- a/tests/ls/removed-directory.sh
++++ b/tests/ls/removed-directory.sh
+@@ -19,6 +19,9 @@
+ # along with this program.  If not, see <https://www.gnu.org/licenses/>.
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
++# Avoid #413621 until #548250 is resolved
++test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
++
+ print_ver_ ls
+ case $host_triplet in
+--- a/tests/ls/stat-free-symlinks.sh
++++ b/tests/ls/stat-free-symlinks.sh
+@@ -17,6 +17,9 @@
+ # along with this program.  If not, see <https://www.gnu.org/licenses/>.
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
++# Avoid #413621 until #548250 is resolved
++test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
++
+ print_ver_ ls
+ require_strace_ stat
+--- a/tests/misc/env-S.pl
++++ b/tests/misc/env-S.pl
+@@ -30,6 +30,11 @@ $env = $1;
+ # Turn off localization of executable's output.
+ @ENV{qw(LANGUAGE LANG LC_ALL)} = ('C') x 3;
++# Skip if sandbox is enabled
++if ($ENV{SANDBOX_ACTIVE}) {
++     CuSkip::skip "Gentoo: Test known bad under sandbox (#675802)\n";
++}
++
+ my @Tests =
+     (
+      # Test combination of -S and regular arguments
+--- a/tests/rm/deep-2.sh
++++ b/tests/rm/deep-2.sh
+@@ -17,6 +17,9 @@
+ # along with this program.  If not, see <https://www.gnu.org/licenses/>.
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
++# Avoid #413621 until #548250 is resolved
++test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
++
+ print_ver_ rm
+ require_perl_