sci-electronics/geda: Add missing library to linker stage.
authorThomas Beierlein <tomjbe@gentoo.org>
Mon, 20 May 2019 16:17:04 +0000 (18:17 +0200)
committerThomas Beierlein <tomjbe@gentoo.org>
Mon, 20 May 2019 16:17:04 +0000 (18:17 +0200)
Thanks for reporting: Constantin Runge <c.runge@cssbook.de>

Closes: https://bugs.gentoo.org/684870
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
sci-electronics/geda/geda-1.9.2-r1.ebuild

index 2a44a907ab440ee321d490bde50dae1cec50b187..08129958fc60f1874f2a4d85ce9c6d20eb2db300 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -52,6 +52,19 @@ src_prepare() {
                sed -i -e 's/\texamples$//' Makefile.in || die
        fi
 
+       # add missing GIO_LIB Bug #684870
+       sed -i -e 's/gsymcheck_LDFLAGS =/gsymcheck_LDFLAGS = $(GIO_LIBS)/' \
+               gsymcheck/src/Makefile.am || die
+
+       sed -i -e 's/gnetlist_LDFLAGS =/gnetlist_LDFLAGS = $(GIO_LIBS)/' \
+               gnetlist/src/Makefile.am || die
+
+       sed -i -e 's/gschlas_LDFLAGS =/gschlas_LDFLAGS = $(GIO_LIBS)/' \
+               utils/gschlas/Makefile.am || die
+
+       sed -i -e 's/sarlacc_schem_LDFLAGS =/sarlacc_schem_LDFLAGS = $(GIO_LIBS)/' \
+               contrib/sarlacc_schem/Makefile.am || die
+
        eautoreconf
 }