app-portage/ufed: Version bump to 0.96.
authorUlrich Müller <ulm@gentoo.org>
Sat, 2 May 2020 08:44:55 +0000 (10:44 +0200)
committerUlrich Müller <ulm@gentoo.org>
Sat, 2 May 2020 08:44:55 +0000 (10:44 +0200)
Closes: https://bugs.gentoo.org/549042
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-portage/ufed/Manifest
app-portage/ufed/ufed-0.96.ebuild [new file with mode: 0644]

index 22b2c6eeea6bb423c761ab52574d7016d292d242..8a86f26e512d793b8023d2a21da071e1f27097cc 100644 (file)
@@ -1,2 +1,3 @@
 DIST ufed-0.94.tar.bz2 48566 BLAKE2B db58624005c637c7133a298c17b60cae3cf54c1b1d2ba3337693e1f6c330a5305986e92b6c1b25a5ebc94b1f8934cb5a35db94eccb596f2eb15619dfb2ce4977 SHA512 a40e55db8afc99b5e16b080d93867ef8c832a7318af7a50edb582bfea99bcc6a467b4bf12b75a9d3943e8a008a0222ed73daa52a8e7dae57d73bece4ac084d24
 DIST ufed-0.95.tar.bz2 48956 BLAKE2B b2bd9210b314814fe9bd1e84ea4ce9de8f3285e5133c989d72284f775c1ed246b0fb641952d4babdf9252cd4b8689afab6b4023099f6c81c81358ab2cbbd9d28 SHA512 010273fc4ff13822ba42f6497a8865c0d29c1d0118b62fd7e2bab66390818fcfb09390fbac671ef612d8e71609fc920b951a11dd42ac79e846d9469a374d2629
+DIST ufed-0.96.tar.bz2 48838 BLAKE2B c160192efb0b68f35454f210068763a54659a9a1904bff6b289aa449fb2ad1583ff727ec201581c0387f794391da9811e8594b57149f7cc47097211cf9bcd976 SHA512 4b4cdd44f793bf41f250e1888d8c2e49ef742ab0b3b3204a04415eea50d73dbdf001a373b125e6ef92450b1081609961d52fb8d98bb8c0fd9010aa549489e4b9
diff --git a/app-portage/ufed/ufed-0.96.ebuild b/app-portage/ufed/ufed-0.96.ebuild
new file mode 100644 (file)
index 0000000..7b1d8fd
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/ufed.git"
+else
+       SRC_URI="https://gitweb.gentoo.org/proj/ufed.git/snapshot/${P}.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+inherit autotools out-of-source
+
+DESCRIPTION="Gentoo Linux USE flags editor"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Ufed"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-lang/perl
+       sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+       default
+       # Change the version number to reflect the ebuild version
+       local REPLACEMENT_VERSION_STR="${PVR}"
+       [[ ${PV} == *9999 ]] && REPLACEMENT_VERSION_STR+="-${EGIT_VERSION}"
+       sed -i "s:,\[git\],:,\[${REPLACEMENT_VERSION_STR}\],:" configure.ac || die
+
+       eautoreconf
+}