sys-devel/gcc-config: drop old
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 23 Mar 2020 23:48:11 +0000 (23:48 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 23 Mar 2020 23:57:57 +0000 (23:57 +0000)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/gcc-config/Manifest
sys-devel/gcc-config/gcc-config-2.2.ebuild [deleted file]

index e0b33baf647eedf50d79386ea417d7d49e056b82..26b532bd1239ff2efd4565591b84b0765d4fdb5d 100644 (file)
@@ -1,3 +1,2 @@
 DIST gcc-config-2.1.tar.xz 15520 BLAKE2B 0e37762877116d90265a31cf6d9bc99da9b358afc26c0f7cb6fdbbb44dce23ebf59a1d5c2e481d456c03fbcc383efb7a56559af0bbd1f2bd78f407a853c88369 SHA512 0b19cb758a1e8c5e2e1f7901799fa1eb598d9d5c8d89ceace2e294ec569bfa90978bef72f52b9c2a3455f2ffd21be0899fb3e23b5fbdf62b70e978c153961272
 DIST gcc-config-2.2.1.tar.xz 16292 BLAKE2B bed319b73bb1dd1c693715654dab7d16c12929353eb28c6e93ffeda0d4539d8204e84287c58de65ed5198011130a6e0ef71421cf41e7cf59cc48781a94ec9af2 SHA512 783caf2f4236d7c84e7c76c2d001d069a1b8544644d7e6e12b79f4dc55f34c953a24a8cd8d01b2aa69fa7f8e02ec3380e0e33a83eda6b3cb00e8c43d2f69f673
-DIST gcc-config-2.2.tar.xz 15956 BLAKE2B c83c1e2584c42d5e6317e044fc6681f5006d9158ecb8d7127383a773e0b51fc2388aab9462088c087a877d77f8ee0631eb00b48b4ef13125af2bbb3871ea2582 SHA512 501d870488ebbeab2e704cab046b6432379c0dcf430fa24737fc97d9a0aa635e25fd4f7c0b7983f349ffd4c378b1971e4c8c82dc524b4916415985a6e0e7480b
diff --git a/sys-devel/gcc-config/gcc-config-2.2.ebuild b/sys-devel/gcc-config/gcc-config-2.2.ebuild
deleted file mode 100644 (file)
index dc534ed..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-if [[ ${PV} == 9999 ]]; then
-       EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gcc-config.git"
-       inherit git-r3
-else
-       SRC_URI="mirror://gentoo/${P}.tar.xz
-               https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
-       KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86"
-fi
-
-DESCRIPTION="Utility to manage compilers"
-HOMEPAGE="https://gitweb.gentoo.org/proj/gcc-config.git/"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND=">=sys-apps/gentoo-functions-0.10"
-
-src_compile() {
-       emake CC="$(tc-getCC)" \
-               PV="${PV}" \
-               SUBLIBDIR="$(get_libdir)"
-}
-
-src_install() {
-       emake \
-               DESTDIR="${D}" \
-               PV="${PV}" \
-               SUBLIBDIR="$(get_libdir)" \
-               install
-}
-
-pkg_postinst() {
-       # Scrub eselect-compiler remains
-       rm -f "${ROOT}"/etc/env.d/05compiler &
-
-       # We not longer use the /usr/include/g++-v3 hacks, as
-       # it is not needed ...
-       rm -f "${ROOT}"/usr/include/g++{,-v3} &
-
-       # Do we have a valid multi ver setup ?
-       local x
-       for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
-               gcc-config ${x}
-       done
-
-       wait
-}