dev-python/astroid: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 11:37:55 +0000 (12:37 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 11:47:54 +0000 (12:47 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/astroid/Manifest
dev-python/astroid/astroid-1.4.8.ebuild [deleted file]
dev-python/astroid/astroid-2.2.5.ebuild [deleted file]
dev-python/astroid/astroid-2.3.3-r1.ebuild [deleted file]
dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch [deleted file]

index 2132d4974b4ff3588bcf1f9aa821aaea2b87a52a..11d953d01e22e7107f66074f99e5d801160024f5 100644 (file)
@@ -1,3 +1 @@
-DIST astroid-1.4.8.tar.gz 184091 BLAKE2B 7180b98c757c8681dd0abaed1e79d2c58ce676aff07b539af8776d589ff23770335d0ba4ce5c9b3940b0428dd10174e7c6eff66aeb500e6ac561734e27975be0 SHA512 54bb20edf5518b417470a2d63210802b267fe727f9d30e1ac5000db00a7894739b1c4249468fb55df81b55d382f3a5bbe019876141f7ee4d94040fd699dc0c2c
-DIST astroid-2.2.5.tar.gz 281829 BLAKE2B 2cc341caac381fb44b0302e8057a6e2105a6a82dbf807f8a59598e15c5658cc30d4c32e3b58ebbc94c4559f2b2274373f5ed6c4b86b4e8eff86dd91a5520e7ce SHA512 71c8c26314f666e2b9519a83dd9476fbfe0ad7d72f5308f6a94b83c5442dc695bc3e51155df45586ff2ff0eec522a02286d00ac566d542f0b82e5e0d0d7d9c65
 DIST astroid-2.3.3.tar.gz 297350 BLAKE2B 7ac5cf028fa0263998271d23128b1bfd127fedafab2f6b3cc465867b9668942e1edc79bed62eb34bcce31b6892e4c5a31dbdd68d20fb92a1f134dc9e78a76920 SHA512 72011f3eb312ea7ce7dd55f7615972f6bfc152d8f16f9052b405f44fe17e594d5da22e0502b4c3034881b9783be9e808509d4ded3d679182ddf6d34eb90748f1
diff --git a/dev-python/astroid/astroid-1.4.8.ebuild b/dev-python/astroid/astroid-1.4.8.ebuild
deleted file mode 100644 (file)
index 60df02b..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="https://bitbucket.org/logilab/astroid https://pypi.org/project/astroid/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ia64 ppc ppc64 sparc x86 ~x64-macos ~x86-macos"
-IUSE="test"
-
-# still broken
-RESTRICT=test
-
-# Version specified in __pkginfo__.py.
-RDEPEND="
-       dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       dev-python/wrapt[${PYTHON_USEDEP}]"
-DEPEND="
-       app-arch/unzip
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-#      test? (
-#              ${RDEPEND}
-#              >=dev-python/pylint-1.4.0[${PYTHON_USEDEP}]
-#              dev-python/pytest[${PYTHON_USEDEP}]
-#              $(python_gen_cond_dep 'dev-python/egenix-mx-base[${PYTHON_USEDEP}]' python2_7)
-#      )"
-# Required for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_test() {
-       ${EPYTHON} -m unittest discover -p "unittest*.py" --verbose || die
-}
diff --git a/dev-python/astroid/astroid-2.2.5.ebuild b/dev-python/astroid/astroid-2.2.5.ebuild
deleted file mode 100644 (file)
index 88949dd..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="https://github.com/PyCQA/astroid https://pypi.org/project/astroid/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Version specified in __pkginfo__.py.
-RDEPEND="
-       dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       dev-python/wrapt[${PYTHON_USEDEP}]
-       >=dev-python/typed-ast-1.3.0[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/numpy[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/python-dateutil[${PYTHON_USEDEP}]
-       )"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-2.1.0-no-pytest-runner.patch"
-)
-
-python_prepare_all() {
-       # Disable failing tests
-
-       # no idea why this test fails
-       sed -i -e "s/test_knownValues_get_builtin_module_part/_&/" \
-               astroid/tests/unittest_modutils.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       ${EPYTHON} -m pytest -v --pyarg astroid/tests || die "tests failed"
-}
diff --git a/dev-python/astroid/astroid-2.3.3-r1.ebuild b/dev-python/astroid/astroid-2.3.3-r1.ebuild
deleted file mode 100644 (file)
index a747cf1..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="https://github.com/PyCQA/astroid https://pypi.org/project/astroid/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ia64 ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Version specified in __pkginfo__.py.
-RDEPEND="
-       dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       >=dev-python/wrapt-1.11.2[${PYTHON_USEDEP}]
-       >=dev-python/typed-ast-1.3.0[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/numpy[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/python-dateutil[${PYTHON_USEDEP}]
-       )"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-2.3.3-no-pytest-runner.patch"
-)
-
-python_prepare_all() {
-       # Disable failing tests
-
-       # no idea why this test fails
-       sed -i -e "s/test_knownValues_get_builtin_module_part/_&/" \
-               astroid/tests/unittest_modutils.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       "${EPYTHON}" -m pytest -v --pyargs astroid/tests \
-               || die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch b/dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch
deleted file mode 100644 (file)
index 94eda17..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 2ad90aac..4628a40f 100644
---- a/setup.py
-+++ b/setup.py
-@@ -42,7 +42,6 @@ def install():
-                  install_requires = install_requires,
-                  extras_require=extras_require,
-                  packages=find_packages(exclude=['astroid.tests']) + ['astroid.brain'],
--                 setup_requires=['pytest-runner'],
-                  test_suite='test',
-                  tests_require=['pytest'],
-                  )