dev-ros/genpy: Add python 3.6 support and use standard ros-catkin.eclass src_test...
authorAlexis Ballier <aballier@gentoo.org>
Mon, 27 Feb 2017 10:28:31 +0000 (11:28 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 27 Feb 2017 10:49:08 +0000 (11:49 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ros/genpy/genpy-0.6.3.ebuild
dev-ros/genpy/genpy-9999.ebuild

index b393c061a86bef4f2d20a8e51135c9e9f1605be4..bd9c129377536cf2b507c6ce469edf7bd60a9d91 100644 (file)
@@ -6,7 +6,7 @@ EAPI=5
 
 ROS_REPO_URI="https://github.com/ros/genpy"
 KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
 
 inherit ros-catkin
 
@@ -23,12 +23,3 @@ DEPEND="${RDEPEND}
                dev-python/nose[${PYTHON_USEDEP}]
        )
 "
-
-python_test() {
-       cd "${BUILD_DIR}"
-       PYTHONPATH="${S}/src" nosetests --verbose -w "${S}/test" || die
-}
-
-src_test() {
-       python_foreach_impl python_test
-}
index b393c061a86bef4f2d20a8e51135c9e9f1605be4..bd9c129377536cf2b507c6ce469edf7bd60a9d91 100644 (file)
@@ -6,7 +6,7 @@ EAPI=5
 
 ROS_REPO_URI="https://github.com/ros/genpy"
 KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
 
 inherit ros-catkin
 
@@ -23,12 +23,3 @@ DEPEND="${RDEPEND}
                dev-python/nose[${PYTHON_USEDEP}]
        )
 "
-
-python_test() {
-       cd "${BUILD_DIR}"
-       PYTHONPATH="${S}/src" nosetests --verbose -w "${S}/test" || die
-}
-
-src_test() {
-       python_foreach_impl python_test
-}