bump for utf8 encoding error from bug #174678
authorCarsten Lohrke <carlo@gentoo.org>
Wed, 25 Apr 2007 08:58:00 +0000 (08:58 +0000)
committerCarsten Lohrke <carlo@gentoo.org>
Wed, 25 Apr 2007 08:58:00 +0000 (08:58 +0000)
Package-Manager: portage-2.1.2.4

kde-base/kdepim/ChangeLog
kde-base/kdepim/files/digest-kdepim-3.5.5-r4 [new file with mode: 0644]
kde-base/kdepim/kdepim-3.5.5-r4.ebuild [new file with mode: 0644]
kde-base/kmail/ChangeLog
kde-base/kmail/files/digest-kmail-3.5.5-r2 [new file with mode: 0644]
kde-base/kmail/kmail-3.5.5-r2.ebuild [new file with mode: 0644]

index 22c2f391e10f60a8b56d042482bb6cfb77548430..0c909a04bb1c11602d832adcd7d393038a749f4d 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for kde-base/kdepim
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/ChangeLog,v 1.260 2007/04/24 17:01:42 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/ChangeLog,v 1.261 2007/04/25 08:56:55 carlo Exp $
+
+*kdepim-3.5.5-r4 (25 Apr 2007)
+
+  25 Apr 2007; Carsten Lohrke <carlo@gentoo.org> +kdepim-3.5.5-r4.ebuild:
+  bump for utf8 encoding error from bug #174678
 
 *kdepim-3.5.6-r3 (24 Apr 2007)
 
diff --git a/kde-base/kdepim/files/digest-kdepim-3.5.5-r4 b/kde-base/kdepim/files/digest-kdepim-3.5.5-r4
new file mode 100644 (file)
index 0000000..0e30ce8
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 48f1592b07f784df47280baa0c8356b0 kdepim-3.5-patchset-03.tar.bz2 121475
+RMD160 e8aa4e812a3be3d4e13429d487e1e4d466e058b1 kdepim-3.5-patchset-03.tar.bz2 121475
+SHA256 30d4e8d7ac4e11f1a8209bbcb5b39beb044998d4b0d3fa810743a017b38b904b kdepim-3.5-patchset-03.tar.bz2 121475
+MD5 3f2127f74cb496899bb3f1f6f702353b kdepim-3.5.5.tar.bz2 12908968
+RMD160 5bdcf98909f450ce3839fa72a404571f6cde22f6 kdepim-3.5.5.tar.bz2 12908968
+SHA256 82887df2c2ff00cb60dcfb8aa04527988123b9a4ed70f4c9082a7a0eb9f1f047 kdepim-3.5.5.tar.bz2 12908968
diff --git a/kde-base/kdepim/kdepim-3.5.5-r4.ebuild b/kde-base/kdepim/kdepim-3.5.5-r4.ebuild
new file mode 100644 (file)
index 0000000..5aa5a15
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-3.5.5-r4.ebuild,v 1.1 2007/04/25 08:56:55 carlo Exp $
+
+inherit kde-dist
+
+SRC_URI="${SRC_URI}
+       mirror://gentoo/kdepim-3.5-patchset-03.tar.bz2"
+
+DESCRIPTION="KDE PIM (Personal Information Management) apps: korganizer, kmail, knode..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt gnokii pda"
+
+# We use GnuPG 1.4.x for OpenPGP and 1.9 (via gpgme) for s/mime as upstream advises.
+DEPEND="~kde-base/kdebase-${PV}
+       >=dev-libs/cyrus-sasl-2
+       pda? ( app-pda/pilot-link dev-libs/libmal )
+       gnokii? ( app-mobilephone/gnokii )
+       crypt? ( >=app-crypt/gpgme-1.1.2-r1
+               || ( >=app-crypt/gnupg-2.0.1-r1 <app-crypt/gnupg-1.9 ) )
+               x11-libs/libXScrnSaver"
+
+RDEPEND="${DEPEND}
+       crypt? ( app-crypt/pinentry )"
+
+DEPEND="${DEPEND}
+       x11-proto/scrnsaverproto"
+
+PATCHES="${FILESDIR}/kmail-utf8.diff"
+
+src_unpack() {
+       kde_src_unpack
+       # Call Qt 3 designer
+       sed -i -e "s:\"designer\":\"${QTDIR}/bin/designer\":g" "${S}"/libkdepim/kcmdesignerfields.cpp || die "sed failed"
+
+       sed -e "s:SUBDIRS = libical versit tests:SUBDIRS = libical versit:" -i libkcal/Makefile.am || die "sed failed"
+}
+
+src_compile() {
+       local myconf="--with-sasl $(use_with gnokii)"
+       use crypt && myconf="${myconf} --with-gpg=/usr/bin/gpg"
+
+       use pda || DO_NOT_COMPILE="${DO_NOT_COMPILE} kpilot"
+
+       kde_src_compile
+}
index f6c8e5ca107176f936ab0dbc869c92f7b24dd7eb..34e274e7b3fda07fc3af1c6c6af2c99c66568f55 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for kde-base/kmail
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.101 2007/04/24 16:57:31 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.102 2007/04/25 08:58:00 carlo Exp $
+
+*kmail-3.5.5-r2 (25 Apr 2007)
+
+  25 Apr 2007; Carsten Lohrke <carlo@gentoo.org> +kmail-3.5.5-r2.ebuild:
+  bump for utf8 encoding error from bug #174678
 
 *kmail-3.5.6-r3 (24 Apr 2007)
 
diff --git a/kde-base/kmail/files/digest-kmail-3.5.5-r2 b/kde-base/kmail/files/digest-kmail-3.5.5-r2
new file mode 100644 (file)
index 0000000..a119724
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 3f2127f74cb496899bb3f1f6f702353b kdepim-3.5.5.tar.bz2 12908968
+RMD160 5bdcf98909f450ce3839fa72a404571f6cde22f6 kdepim-3.5.5.tar.bz2 12908968
+SHA256 82887df2c2ff00cb60dcfb8aa04527988123b9a4ed70f4c9082a7a0eb9f1f047 kdepim-3.5.5.tar.bz2 12908968
diff --git a/kde-base/kmail/kmail-3.5.5-r2.ebuild b/kde-base/kmail/kmail-3.5.5-r2.ebuild
new file mode 100644 (file)
index 0000000..bdeba2b
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-3.5.5-r2.ebuild,v 1.1 2007/04/25 08:58:00 carlo Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_DIR="${SRC_DIR}
+       mirror://gentoo/kdepim-3.5-patchset-02.tar.bz2"
+
+DESCRIPTION="KDE mail client"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt"
+DEPEND="$(deprange 3.5.4 $MAXKDEVER kde-base/libkdenetwork)
+       $(deprange $PV $MAXKDEVER kde-base/libkdepim)
+       $(deprange $PV $MAXKDEVER kde-base/libkpimidentities)
+       $(deprange 3.5.4 $MAXKDEVER kde-base/mimelib)
+       $(deprange 3.5.0 $MAXKDEVER kde-base/libksieve)
+       $(deprange $PV $MAXKDEVER kde-base/certmanager)
+       $(deprange $PV $MAXKDEVER kde-base/libkcal)
+       $(deprange $PV $MAXKDEVER kde-base/kontact)
+       $(deprange 3.5.4 $MAXKDEVER kde-base/libkpgp)
+       $(deprange 3.5.3 $MAXKDEVER kde-base/libkmime)"
+RDEPEND="${DEPEND}
+       crypt? ( app-crypt/pinentry )
+       $(deprange $PV $MAXKDEVER kde-base/kdepim-kioslaves)
+       $(deprange $PV $MAXKDEVER kde-base/kmailcvt)
+       $(deprange-dual $PV $MAXKDEVER kde-base/kdebase-kioslaves)
+       $(deprange-dual $PV $MAXKDEVER kde-base/kcontrol)" # for the "looknfeel" icon, and probably others.
+
+KMCOPYLIB="
+       libkdepim libkdepim/
+       libkpimidentities libkpimidentities/
+       libmimelib mimelib/
+       libksieve libksieve/
+       libkleopatra certmanager/lib/
+       libkcal libkcal
+       libkpinterfaces kontact/interfaces/
+       libkmime libkmime
+       libkpgp libkpgp"
+KMEXTRACTONLY="
+       libkdenetwork/
+       libkdepim/
+       libkpimidentities/
+       libksieve/
+       libkcal/
+       mimelib/
+       certmanager/
+       korganizer/korganizeriface.h
+       kontact/interfaces/
+       libkmime/
+       libkpgp
+       dcopidlng"
+KMCOMPILEONLY="libemailfunctions"
+# the kmail plugins are installed with kmail
+KMEXTRA="plugins/kmail/
+       kontact/plugins/kmail/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+PATCHES="${FILESDIR}/${P}-dimap-mail-loss.patch
+       ${FILESDIR}/kmail-utf8.diff"