Version bump and old versions cleanup.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 28 Dec 2006 16:10:37 +0000 (16:10 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 28 Dec 2006 16:10:37 +0000 (16:10 +0000)
Package-Manager: portage-2.1.2_rc4-r1

net-libs/libtorrent/ChangeLog
net-libs/libtorrent/files/digest-libtorrent-0.11.1 [new file with mode: 0644]
net-libs/libtorrent/libtorrent-0.11.1.ebuild [new file with mode: 0644]

index ecfcd37229385522a59c884fb73cf268a508f5c5..063b5d8da72579bd680d136d0a89f5642146b955 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-libs/libtorrent
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.81 2006/12/17 16:00:34 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.82 2006/12/28 16:10:36 flameeyes Exp $
+
+*libtorrent-0.11.1 (28 Dec 2006)
+
+  28 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+  -libtorrent-0.10.0.ebuild, -libtorrent-0.11.0.ebuild,
+  +libtorrent-0.11.1.ebuild:
+  Version bump and old versions cleanup.
 
   17 Dec 2006; Tobias Scherbaum <dertobi123@gentoo.org>
   libtorrent-0.10.4.ebuild:
diff --git a/net-libs/libtorrent/files/digest-libtorrent-0.11.1 b/net-libs/libtorrent/files/digest-libtorrent-0.11.1
new file mode 100644 (file)
index 0000000..2b29b28
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 d1a98c0bd93839071b8c214453aa4e5c libtorrent-0.11.1.tar.gz 477557
+RMD160 f28327d0ebb2a608e3fa3f6f3414db150cc2d000 libtorrent-0.11.1.tar.gz 477557
+SHA256 3a747a03b2f683e71ed3eab2fa2e66689ba58e5d9a17527579583b86f4de46e1 libtorrent-0.11.1.tar.gz 477557
diff --git a/net-libs/libtorrent/libtorrent-0.11.1.ebuild b/net-libs/libtorrent/libtorrent-0.11.1.ebuild
new file mode 100644 (file)
index 0000000..9046fec
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.1.ebuild,v 1.1 2006/12/28 16:10:37 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+       >=dev-util/pkgconfig-0.11"
+
+src_compile() {
+       replace-flags -Os -O2
+
+       if [[ $(tc-arch) = "x86" ]]; then
+               filter-flags -fomit-frame-pointer -fforce-addr
+
+               # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+               # it could be safer to fallback to -O1, but with the high use of STL in
+               # rtorrent, that could make it too slow.
+               [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+       fi
+
+       elibtoolize
+       econf \
+               $(use_enable debug) \
+               --disable-dependency-tracking \
+               || die "econf failed"
+
+       emake || die "emake failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "make install failed"
+       dodoc AUTHORS ChangeLog NEWS README TODO
+}