media-sound/tomahawk: Try to fix build with <cmake-3.10
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 26 Jan 2019 08:35:20 +0000 (09:35 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 26 Jan 2019 08:46:16 +0000 (09:46 +0100)
Bug: https://bugs.gentoo.org/674826
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-cmakepolicy.patch [new file with mode: 0644]
media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild

diff --git a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-cmakepolicy.patch b/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-cmakepolicy.patch
new file mode 100644 (file)
index 0000000..7ddf116
--- /dev/null
@@ -0,0 +1,37 @@
+From 663981b4dd28fca6cac0b079bed26c411e7d1722 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Fri, 25 Jan 2019 21:13:05 +0100
+Subject: [PATCH] Fix build with <cmake-3.10
+
+---
+ CMakeLists.txt | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b44d2ee43..9422a808e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,14 +2,18 @@ PROJECT( tomahawk )
+ CMAKE_MINIMUM_REQUIRED( VERSION 2.8.12 )
+ CMAKE_POLICY(SET CMP0017 NEW)
+ CMAKE_POLICY(SET CMP0022 NEW)
+-CMAKE_POLICY(SET CMP0075 NEW)
++IF(POLICY CMP0075)
++    CMAKE_POLICY(SET CMP0075 NEW)
++ENDIF()
+ # TODO:
+ # Update to NEW and fix things up
+ CMAKE_POLICY(SET CMP0023 NEW)
+ # Let AUTOMOC and AUTOUIC process generated files
+-CMAKE_POLICY(SET CMP0071 NEW)
++IF(POLICY CMP0071)
++    CMAKE_POLICY(SET CMP0071 NEW)
++ENDIF()
+ # TODO:
+ # Disable automatic qtmain linking
+-- 
+2.20.1
+
index b9e80fa1ed9ed60cf83e1ef4a9a9178c589f838b..82c9537fd054bed8eeae0d0bebe5efbf1073c38a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -53,7 +53,10 @@ RDEPEND="${COMMON_DEPEND}
 
 S="${WORKDIR}/${PN}-${COMMIT}"
 
-PATCHES=( "${FILESDIR}/${P}-fix-warning.patch" )
+PATCHES=(
+       "${FILESDIR}/${P}-fix-warning.patch"
+       "${FILESDIR}/${P}-cmakepolicy.patch" # bug 674826
+)
 
 src_configure() {
        local mycmakeargs=(