media-gfx/enblend: EAPI-7 bump, fix unused cmake vars
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 8 Nov 2019 21:35:48 +0000 (22:35 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 8 Nov 2019 21:38:33 +0000 (22:38 +0100)
Closes: https://bugs.gentoo.org/665384
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/enblend/enblend-4.2.0_p20161007-r1.ebuild

index b50a745f437a61bec5fb796907c0ae68203750a4..51f0c069d6ee831539e8c38f98cf0063e27e49e1 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit cmake-utils
 
@@ -12,23 +12,12 @@ SRC_URI="https://dev.gentoo.org/~soap/distfiles/${P}.tar.xz"
 LICENSE="GPL-2+ FDL-1.2+"
 SLOT="0"
 KEYWORDS="amd64 arm64 x86"
-IUSE="debug doc openmp tcmalloc cpu_flags_x86_sse2"
+IUSE="cpu_flags_x86_sse2 debug doc openmp tcmalloc"
 
 REQUIRED_USE="tcmalloc? ( !debug )"
 
-RDEPEND="
-       media-libs/lcms:2
-       media-libs/openexr:=
-       media-libs/tiff:0
-       media-libs/vigra[openexr]
-       sci-libs/gsl:=
-       debug? ( dev-libs/dmalloc )
-       tcmalloc? ( dev-util/google-perftools )"
-DEPEND="${RDEPEND}
-       >=dev-libs/boost-1.62.0
-       media-libs/libpng:0
+BDEPEND="
        sys-apps/help2man
-       virtual/jpeg:0
        virtual/pkgconfig
        doc? (
                dev-lang/perl
@@ -40,7 +29,22 @@ DEPEND="${RDEPEND}
                sci-visualization/gnuplot[gd]
                virtual/imagemagick-tools
                virtual/latex-base
-       )"
+       )
+"
+RDEPEND="
+       media-libs/lcms:2
+       media-libs/openexr:=
+       media-libs/tiff:0
+       media-libs/vigra[openexr]
+       sci-libs/gsl:=
+       debug? ( dev-libs/dmalloc )
+       tcmalloc? ( dev-util/google-perftools )
+"
+DEPEND="${RDEPEND}
+       >=dev-libs/boost-1.62.0
+       media-libs/libpng:0
+       virtual/jpeg:0
+"
 
 PATCHES=(
        "${FILESDIR}"/${PN}-4.2-doc-install-dir-fix.patch
@@ -55,14 +59,17 @@ src_prepare() {
 
 src_configure() {
        local mycmakeargs=(
+               -DENABLE_SSE2=$(usex cpu_flags_x86_sse2)
                -DENABLE_DMALLOC=$(usex debug)
-               -DENABLE_TCMALLOC=$(usex tcmalloc)
                -DDOC=$(usex doc)
-               -DINSTALL_HTML_DOC=$(usex doc)
-               -DINSTALL_PDF_DOC=$(usex doc)
                -DENABLE_OPENMP=$(usex openmp)
-               -DENABLE_SSE2=$(usex cpu_flags_x86_sse2)
+               -DENABLE_TCMALLOC=$(usex tcmalloc)
        )
+       if use doc; then
+               -DINSTALL_HTML_DOC=ON
+               -DINSTALL_PDF_DOC=ON
+       fi
+
        cmake-utils_src_configure
 }