version bump and init script fix thanks to Jon Hood <squinky86@gentoo.org> in bugs...
authorStefan Schweizer <genstef@gentoo.org>
Fri, 16 Jun 2006 09:02:06 +0000 (09:02 +0000)
committerStefan Schweizer <genstef@gentoo.org>
Fri, 16 Jun 2006 09:02:06 +0000 (09:02 +0000)
Package-Manager: portage-2.1

net-misc/ajaxterm/ChangeLog
net-misc/ajaxterm/ajaxterm-0.7.ebuild [new file with mode: 0644]
net-misc/ajaxterm/files/digest-ajaxterm-0.7 [new file with mode: 0644]

index b618bdf30cc2ac9a4d493961f5ed9582364e5969..dd7990ba3f8befeff9625c53c7ae0ea82e52abfa 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-misc/ajaxterm
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ajaxterm/ChangeLog,v 1.2 2006/05/30 11:34:20 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ajaxterm/ChangeLog,v 1.3 2006/06/16 09:02:06 genstef Exp $
+
+  16 Jun 2006; Stefan Schweizer <genstef@gentoo.org> -ajaxterm-0.6.ebuild,
+  +ajaxterm-0.7.ebuild:
+  version bump and init script fix thanks to Jon Hood <squinky86@gentoo.org>
+  in bugs 136945 and 136946
 
 *ajaxterm-0.6 (28 May 2006)
 
diff --git a/net-misc/ajaxterm/ajaxterm-0.7.ebuild b/net-misc/ajaxterm/ajaxterm-0.7.ebuild
new file mode 100644 (file)
index 0000000..042fe57
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ajaxterm/ajaxterm-0.7.ebuild,v 1.1 2006/06/16 09:02:06 genstef Exp $
+
+MY_P=Ajaxterm-${PV}
+DESCRIPTION="Ajaxterm is a web based terminal"
+HOMEPAGE="http://antony.lesuisse.org/qweb/trac/wiki/AjaxTerm"
+SRC_URI="http://antony.lesuisse.org/qweb/files/${MY_P}.tar.gz"
+
+LICENSE="public-domain LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.0"
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+       # baselayout's start-stop-daemon wrapper does not allow shell scripts
+       sed -i -e "s: -- :\0/usr/share/ajaxterm/ajaxterm.py :" \
+               -e "s:\(DAEMON=%(bin)s/\)ajaxterm:\1python:" configure.initd.gentoo
+
+       ./configure --prefix=/usr || die "./configure failed"
+}
+
+src_install() {
+       dodir /etc/init.d
+       sed -i -e "s:\"/usr:\"${D}/usr:" \
+               -e "s:\"/etc:\"${D}/etc:" \
+               -e "s:/usr/man:/usr/share/man:" Makefile
+       emake install || die "emake install failed"
+}
+
+pkg_postinst() {
+       ewarn "For remote access, it is strongly recommended to use https SSL/TLS"
+       ewarn "On the website is a config for apache web server using mod_proxy"
+}
diff --git a/net-misc/ajaxterm/files/digest-ajaxterm-0.7 b/net-misc/ajaxterm/files/digest-ajaxterm-0.7
new file mode 100644 (file)
index 0000000..c29a768
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 7b6bb5338c98f7a4dc0f0898becfacd7 Ajaxterm-0.7.tar.gz 32968
+RMD160 7672884fa0ab98da81a0c0442e972bd82a944960 Ajaxterm-0.7.tar.gz 32968
+SHA256 6c33a8b067415745dc1235216ef6fc89487e053d561cf58eccaf7ecf20de668f Ajaxterm-0.7.tar.gz 32968