net-wireless/blueman: Call eautomake to replace py-compile
authorMichał Górny <mgorny@gentoo.org>
Sun, 3 Nov 2019 11:26:52 +0000 (12:26 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 8 Nov 2019 09:47:44 +0000 (10:47 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/13535
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-wireless/blueman/blueman-2.1.1.ebuild
net-wireless/blueman/blueman-9999.ebuild

index 6f86023ac9c9499d8f6b0d23db39d780d2820b88..afa7dd91ce100e2477222c8c6b1d0b0184387bf9 100644 (file)
@@ -4,13 +4,13 @@
 EAPI="7"
 
 PYTHON_COMPAT=( python3_{5,6,7} )
-inherit gnome2-utils linux-info python-single-r1 systemd xdg-utils
+inherit autotools gnome2-utils linux-info python-single-r1 systemd xdg-utils
 
 DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
 HOMEPAGE="https://github.com/blueman-project/blueman"
 
 if [[ ${PV} == "9999" ]] ; then
-       inherit autotools git-r3
+       inherit git-r3
        EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
        KEYWORDS=""
 else
@@ -78,7 +78,8 @@ pkg_setup() {
 
 src_prepare() {
        default
-       [[ ${PV} == 9999 ]] && eautoreconf
+       # replace py-compile to fix py3
+       [[ ${PV} == 9999 ]] && eautoreconf || eautomake
 }
 
 src_configure() {
index 685f3219bdb66c74877e68cd5b42f080ee6eafd9..4e3c0edd40da9d4b9c328e059f642cd356c6433b 100644 (file)
@@ -4,13 +4,13 @@
 EAPI="7"
 
 PYTHON_COMPAT=( python3_{5,6,7} )
-inherit gnome2-utils linux-info python-single-r1 systemd xdg-utils
+inherit autotools gnome2-utils linux-info python-single-r1 systemd xdg-utils
 
 DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
 HOMEPAGE="https://github.com/blueman-project/blueman"
 
 if [[ ${PV} == "9999" ]] ; then
-       inherit autotools git-r3
+       inherit git-r3
        EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
        KEYWORDS=""
 else
@@ -76,7 +76,8 @@ pkg_setup() {
 
 src_prepare() {
        default
-       [[ ${PV} == 9999 ]] && eautoreconf
+       # replace py-compile to fix py3
+       [[ ${PV} == 9999 ]] && eautoreconf || eautomake
 }
 
 src_configure() {