dev-python/gevent: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:03:19 +0000 (13:03 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:03:19 +0000 (13:03 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/gevent/Manifest
dev-python/gevent/gevent-1.3.7.ebuild [deleted file]

index 75464960c707508406fdf71b4acb1a8e57a669d2..aaa890a7697e827542a77a01c62a1e1600426b16 100644 (file)
@@ -1,2 +1 @@
-DIST gevent-1.3.7.tar.gz 4614437 BLAKE2B 43d50c36fba2bedf41a7b33d38180f096b18846146953fa68325155f4a3cb6edb7352b9bb4cff5c7eca7a06ac25dc5b3e82a04545704fd0d6f43e9839a8749a1 SHA512 6dba487a9527eb352dc6a5f57120bf7973da655b3a331cad6637271b626c6e9e5439b20ee8abd9035ecb36e5259c99c69dea5ecdb8fa7ad0dbe28876c4d746d8
 DIST gevent-1.4.0.tar.gz 5169595 BLAKE2B 0c78f67bc94d15419b8eadf8825d9657c6a7a82756308216e1ca94d5465c25836cb736b8b370a12d1003eb8614effd4110d8ed47ee2b0d7febc2bda4038adc0a SHA512 6771f4f2932055270e4f5a79ae815e93fd0f471defa7f437dc84907ea8b44672e05ae5eb6958f8d90580b2471785dce4044d9d1bbea0dd0c34c1381d88af0344
diff --git a/dev-python/gevent/gevent-1.3.7.ebuild b/dev-python/gevent/gevent-1.3.7.ebuild
deleted file mode 100644 (file)
index ca3ff75..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-PYTHON_REQ_USE="ssl(+),threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-MY_PV=${PV/_beta/b}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Coroutine-based network library"
-HOMEPAGE="http://gevent.org/ https://pypi.org/project/gevent/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND="
-       >=dev-libs/libev-4.23
-       >=net-dns/c-ares-1.12
-       >=dev-python/greenlet-0.4.14
-       virtual/python-greenlet[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# Tests take long and fail terribly a few times.
-# It also seems that they require network access.
-RESTRICT="test"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
-       export LIBEV_EMBED="false"
-       export CARES_EMBED="false"
-       export EMBED="false"
-
-       distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
-       append-flags -fno-strict-aliasing
-}
-
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
-python_test() {
-       cd src/greentest || die
-
-       GEVENT_RESOLVER=thread \
-               "${PYTHON}" testrunner.py --config known_failures.py || die
-       GEVENT_RESOLVER=ares GEVENTARES_SERVERS=8.8.8.8 \
-               "${PYTHON}" testrunner.py --config known_failures.py \
-               --ignore tests_that_dont_use_resolver.txt || die
-       GEVENT_FILE=thread \
-               "${PYTHON}" testrunner.py --config known_failures.py $(grep -l subprocess test_*.py) || die
-}
-
-python_install_all() {
-       local DOCS=( AUTHORS README.rst )
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       use examples && dodoc -r examples
-
-       distutils-r1_python_install_all
-}