app-pda/libplist: Don't prefer clang in 2.1.0
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 28 Mar 2020 13:29:57 +0000 (13:29 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 28 Mar 2020 13:31:49 +0000 (13:31 +0000)
Closes: https://bugs.gentoo.org/714076
Package-Manager: Portage-2.3.96, Repoman-2.3.20
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
app-pda/libplist/libplist-2.1.0.ebuild

index c3222d61087545ec2f611c8ae6722e81670b550e..7b342d04b16d8fa3cf0b97dd593a89609fd199ec 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python3_{6,7,8} )
-inherit autotools python-r1
+inherit autotools python-r1 toolchain-funcs
 
 DESCRIPTION="Support library to deal with Apple Property Lists (Binary & XML)"
 HOMEPAGE="https://www.libimobiledevice.org/"
@@ -49,13 +49,16 @@ src_configure() {
                do_configure "$@"
        }
 
+       # Don't prefer clang.
+       tc-export CC CXX
+
        do_configure --without-cython
        use python && python_foreach_impl do_configure_python
 }
 
 src_compile() {
        python_compile() {
-               emake -C "${BUILD_DIR}"/cython -j1 \
+               emake -C "${BUILD_DIR}"/cython \
                        VPATH="${S}/cython:${native_builddir}/cython" \
                        plist_la_LIBADD="${native_builddir}/src/libplist.la"
        }
@@ -73,7 +76,7 @@ src_test() {
 
 src_install() {
        python_install() {
-               emake -C "${BUILD_DIR}/cython" -j1 \
+               emake -C "${BUILD_DIR}/cython" \
                        VPATH="${S}/cython:${native_builddir}/cython" \
                        DESTDIR="${D}" install
        }