sci-libs/fftw: update live ebuild, migrate to CPU_FLAGS_PPC
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 16 Mar 2020 02:48:15 +0000 (19:48 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Wed, 25 Mar 2020 05:23:18 +0000 (22:23 -0700)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/14975
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
sci-libs/fftw/fftw-9999.ebuild

index 3e2234048b5397027004d1eb0916d1f1df4c5b74..718aed13b25a6d8bba454e742d8cf1d189503479 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -22,7 +22,7 @@ fi
 
 LICENSE="GPL-2+"
 SLOT="3.0/3"
-IUSE="altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
+IUSE="cpu_flags_ppc_altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
@@ -94,7 +94,7 @@ multilib_src_configure() {
                        # altivec, sse, single-paired only work for single
                        myconf+=(
                                --enable-single
-                               $(use_enable altivec)
+                               $(use_enable cpu_flags_ppc_altivec altivec)
                                $(use_enable cpu_flags_x86_avx avx)
                                $(use_enable cpu_flags_x86_avx2 avx2)
                                $(use_enable cpu_flags_x86_sse sse)