sys-kernel/linux-firmware: synchronize live ebuild
authorThomas Deutschmann <whissi@gentoo.org>
Wed, 18 Mar 2020 19:49:10 +0000 (20:49 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Wed, 18 Mar 2020 19:53:09 +0000 (20:53 +0100)
...while there, use "-gt" for better readability.

Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-kernel/linux-firmware/linux-firmware-20200316.ebuild
sys-kernel/linux-firmware/linux-firmware-99999999.ebuild

index 3e7ea3c45bb0fab460955263ecf142a4ea4c71dd..6aa47ba49187227d54c9071a8060335db9b7539f 100644 (file)
@@ -84,7 +84,7 @@ src_unpack() {
        else
                default
                # rename directory from git snapshot tarball
-               if [[ ${#GIT_COMMIT} > 8 ]]; then
+               if [[ ${#GIT_COMMIT} -gt 8 ]]; then
                        mv ${PN}-*/ ${P} || die
                fi
        fi
index 7bc4d9624e2d4bd2dda398b5b80bd58c21bc58ef..b118008def6d4676185221cdab087755205943ec 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -84,7 +84,9 @@ src_unpack() {
        else
                default
                # rename directory from git snapshot tarball
-               mv ${PN}-*/ ${P} || die
+               if [[ ${#GIT_COMMIT} -gt 8 ]]; then
+                       mv ${PN}-*/ ${P} || die
+               fi
        fi
 }