Add a -q (quiet) flag to update-usbids and have the cronjob use it #164800 by Horst...
authorMike Frysinger <vapier@gentoo.org>
Sat, 10 Feb 2007 00:41:28 +0000 (00:41 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 10 Feb 2007 00:41:28 +0000 (00:41 +0000)
Package-Manager: portage-2.1.2-r9

sys-apps/usbutils/ChangeLog
sys-apps/usbutils/files/digest-usbutils-0.72-r1 [new file with mode: 0644]
sys-apps/usbutils/files/usbutils-0.72-update-usbids.patch [new file with mode: 0644]
sys-apps/usbutils/files/usbutils.cron
sys-apps/usbutils/usbutils-0.72-r1.ebuild [new file with mode: 0644]

index 50ff21e9a3131e24b8ab1f7c0f51ab31cea577ba..3e6f0e9c8f53c5a1171a5dea1cc7a0dc152023b4 100644 (file)
@@ -1,6 +1,20 @@
 # ChangeLog for sys-apps/usbutils
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.49 2007/01/19 04:20:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.50 2007/02/10 00:41:28 vapier Exp $
+
+  10 Feb 2007; Mike Frysinger <vapier@gentoo.org>
+  +files/usbutils-0.72-update-usbids.patch, files/usbutils.cron,
+  +usbutils-0.72-r1.ebuild:
+  Add a -q (quiet) flag to update-usbids and have the cronjob use it #164800
+  by Horst Prote.
+
+*usbutils-0.72-r1 (10 Feb 2007)
+
+  10 Feb 2007; Mike Frysinger <vapier@gentoo.org>
+  +files/usbutils-0.72-update-usbids.patch, files/usbutils.cron,
+  +usbutils-0.72-r1.ebuild:
+  Add a -q (quiet) flag to update-usbids and have th cronjob use it #164800 by
+  Horst Prote.
 
 *usbutils-0.72 (19 Jan 2007)
 
diff --git a/sys-apps/usbutils/files/digest-usbutils-0.72-r1 b/sys-apps/usbutils/files/digest-usbutils-0.72-r1
new file mode 100644 (file)
index 0000000..914cebd
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ee345fe605ffcfce843dae4aed81122b usbutils-0.72.tar.gz 166354
+RMD160 7af32b146e196d1df3de8e403fa92137bfe3d4c7 usbutils-0.72.tar.gz 166354
+SHA256 00385353242173b878413e0423c1dddcbbb50a3cadc3bb9d0a6adcf335794423 usbutils-0.72.tar.gz 166354
diff --git a/sys-apps/usbutils/files/usbutils-0.72-update-usbids.patch b/sys-apps/usbutils/files/usbutils-0.72-update-usbids.patch
new file mode 100644 (file)
index 0000000..f049c22
--- /dev/null
@@ -0,0 +1,31 @@
+--- update-usbids.sh
++++ update-usbids.sh
+@@ -2,12 +2,22 @@
+ # see also update-pciids.sh (fancier)
++[ "$1" = "-q" ] && quiet="true" || quiet="false"
++
+ set -e
+ SRC="http://www.linux-usb.org/usb.ids"
+ DEST=usb.ids
++# if usb.ids is read-only (because the filesystem is read-only),
++# then just skip this whole process.
++if ! touch ${DEST} >&2 >/dev/null ; then
++      ${quiet} || echo "${DEST} is read-only, exiting."
++      exit 0
++fi
++
+ if which wget >/dev/null ; then
+       DL="wget -O $DEST.new $SRC"
++      ${quiet} && DL="$DL -q"
+ elif which lynx >/dev/null ; then
+       DL="eval lynx -source $SRC >$DEST.new"
+ else
+@@ -33,4 +43,4 @@
+ fi
+ mv $DEST.new $DEST
+-echo "Done."
++${quiet} || echo "Done."
index fd6da3b3ee7a94fe462ea4cfcf275f888721ad62..1018546d18febe10840ecf9a0e6a3edbb78e2cd0 100755 (executable)
@@ -1,2 +1,2 @@
 #!/bin/sh
-exec /usr/sbin/update-usbids
+exec /usr/sbin/update-usbids -q
diff --git a/sys-apps/usbutils/usbutils-0.72-r1.ebuild b/sys-apps/usbutils/usbutils-0.72-r1.ebuild
new file mode 100644 (file)
index 0000000..fa07ead
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-0.72-r1.ebuild,v 1.1 2007/02/10 00:41:28 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="USB enumeration utilities"
+HOMEPAGE="http://linux-usb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linux-usb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/libusb"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}"/${P}-update-usbids.patch
+
+       # put usb.ids in same place as pci.ids (/usr/share/misc)
+       sed -i \
+               -e 's:/usr/share/usb.ids:/usr/share/misc/usb.ids:' \
+               lsusb.8 || die "sed lsusb.8"
+       sed -e '/^DEST=/s:=usb.ids:=/usr/share/misc/usb.ids:' \
+               update-usbids.sh > update-usbids
+}
+
+src_compile() {
+       econf \
+               --datadir=/usr/share/misc \
+               --enable-usbmodules \
+               || die "./configure failed"
+       emake || die "make failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "install failed"
+       dosbin update-usbids || die "update-usbids failed"
+       dodoc AUTHORS ChangeLog NEWS README
+
+       exeinto /etc/cron.monthly
+       newexe "${FILESDIR}"/usbutils.cron update-usbids || die
+}