dev-python/pytest: remove old
authorVirgil Dupras <vdupras@gentoo.org>
Fri, 10 May 2019 12:53:01 +0000 (08:53 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Fri, 10 May 2019 12:53:01 +0000 (08:53 -0400)
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-python/pytest/Manifest
dev-python/pytest/pytest-3.2.2.ebuild [deleted file]

index 7c446304250433f3607573e327eb8a04b1f0db45..b7466c51aab19655464ef0cf4147f3b2eb560406 100644 (file)
@@ -1,4 +1,3 @@
 DIST pytest-3.10.1.tar.gz 892420 BLAKE2B 38849ae69bf4380bc1a99aa105cac04be078da4460373dfc16fa555238b2830fa2f5ae6c19de8aa2af9ac18d87c5d2705d62f7b2e67e4a62d843f6a28bbd76fd SHA512 30ff79c0fdcbeef68e1191ff400a20428e391717f06957f554b694b94baaaa565dca01346fe989c3e443c4402f3b2bdbd5564f6303a4447f933fb54cba45628f
-DIST pytest-3.2.2.tar.gz 786396 BLAKE2B e669da930890e902b0323ec3a6685080ddd889e74655f7b4cb08ec421651f987597021a31471aab5a32d637b99620ce7792cbdf8f85561db3bb10ff06a446ba1 SHA512 6df3a50e7d1efeaf7a283920b16d1daf800798f422bc851b0aacd2bbd5cb0a88c95f9057fae49943b9dfe6527ed552cdf8d983b944ab91d0af252ee4f6eb82db
 DIST pytest-3.4.2.tar.gz 812719 BLAKE2B 96623d6cdea4bd79778175c18c949938505f1862010f700f9a8cb85f445910381af391a5b69e664fbbfc254bf46502c798c72026772070236a0a3bca7aeeb3d6 SHA512 787065ab76d4482799bb2da9f024c9c383e68cc1cc01f3b80f6ed9444ca6383d20953615696ed4dd01668777b094cf5002b23c4ce51828879dcf8ebf2170c71b
 DIST pytest-4.4.1.tar.gz 931385 BLAKE2B 490b7e931282f35a5d0a83d0e34057bd30e2d2188748e1dad5a09261e27e043e59ae21af24ef39345a1d566f35dd30ef0f877dcb26a927da31a79cc88c52dbe5 SHA512 a4bc18fe7d8db5433d4d52c0ced38d3d0e6a785710bdc772e007fb1f0f516db2267e608845e075ce4d69a5e71a5e741cc6d84b04622e0a04bd2ad3b6576a1473
diff --git a/dev-python/pytest/pytest-3.2.2.ebuild b/dev-python/pytest/pytest-3.2.2.ebuild
deleted file mode 100644 (file)
index 3aead27..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.33"
-COMMON_DEPEND="
-       >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? (
-               dev-python/pyyaml[${PYTHON_USEDEP}]
-               dev-python/sphinx[${PYTHON_USEDEP}]
-       )"
-
-DEPEND="${COMMON_DEPEND}
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/hypothesis-3.5.2[${PYTHON_USEDEP}]
-               >dev-python/pytest-xdist-1.13[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/requests[${PYTHON_USEDEP}]
-       )"
-
-RDEPEND="
-       ${COMMON_DEPEND}
-       !<dev-python/logilab-common-1.3.0"
-
-python_prepare_all() {
-       chmod o-w *egg*/* || die
-       # Disable versioning of py.test script to avoid collision with
-       # versioning performed by the eclass.
-       sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
-       grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
-
-       # Something in the ebuild environment causes this to hang/error.
-       # https://bugs.gentoo.org/598442
-       rm testing/test_pdb.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       # test_nose.py not written to suit py3.2 in pypy3
-       if [[ "${EPYTHON}" == pypy3 ]]; then
-               "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
-                       --ignore=testing/BUILD_nose.py \
-                       || die "tests failed with ${EPYTHON}"
-       else
-               "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX testing || die "tests failed with ${EPYTHON}"
-       fi
-}
-
-python_compile_all(){
-       use doc && emake -C doc/en html
-}
-
-python_install_all() {
-       use doc && HTML_DOCS=( doc/en/_build/html/. )
-       distutils-r1_python_install_all
-}