app-i18n/man-pages-pl: Fix file collision with sys-process/procps.
authorUlrich Müller <ulm@gentoo.org>
Sat, 14 Dec 2019 09:55:56 +0000 (10:55 +0100)
committerUlrich Müller <ulm@gentoo.org>
Sat, 14 Dec 2019 09:57:15 +0000 (10:57 +0100)
Bug: https://bugs.gentoo.org/702276
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild [new file with mode: 0644]

diff --git a/app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild b/app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild
new file mode 100644 (file)
index 0000000..ef7e788
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PKG=manpages-pl-${PV}
+
+DESCRIPTION="A collection of Polish translations of Linux manual pages"
+HOMEPAGE="https://sourceforge.net/projects/manpages-pl/"
+SRC_URI="mirror://sourceforge/manpages-pl/${MY_PKG}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+
+DOCS=( AUTHORS README )
+
+S="${WORKDIR}/${MY_PKG}"
+
+src_prepare() {
+       default
+
+       #mans provided by other packages
+       rm generated/man1/{free,groups,uptime}.1 \
+               po/man1/{free,groups,uptime}.1.po \
+               || die "Failed to clean up duplicates from build directory!"
+}
+
+src_install() {
+       emake install DESTDIR="${D}" COMPRESSOR=:
+}