dev-perl/Text-Kakasi: EAPI6 + tests
authorKent Fredric <kentnl@gentoo.org>
Thu, 15 Mar 2018 08:25:09 +0000 (21:25 +1300)
committerKent Fredric <kentnl@gentoo.org>
Thu, 15 Mar 2018 08:25:09 +0000 (21:25 +1300)
- EAPI6ify
- gitify patches
- Enable tests

Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-perl/Text-Kakasi/Text-Kakasi-2.40.0-r2.ebuild [new file with mode: 0644]
dev-perl/Text-Kakasi/files/Text-Kakasi-2.04-makefile.patch [new file with mode: 0644]

diff --git a/dev-perl/Text-Kakasi/Text-Kakasi-2.40.0-r2.ebuild b/dev-perl/Text-Kakasi/Text-Kakasi-2.40.0-r2.ebuild
new file mode 100644 (file)
index 0000000..e34245d
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DANKOGAI
+DIST_VERSION=2.04
+inherit perl-module
+
+DESCRIPTION="This module provides libkakasi interface for Perl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND=">=app-i18n/kakasi-2.3.4"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.04-makefile.patch )
diff --git a/dev-perl/Text-Kakasi/files/Text-Kakasi-2.04-makefile.patch b/dev-perl/Text-Kakasi/files/Text-Kakasi-2.04-makefile.patch
new file mode 100644 (file)
index 0000000..118d924
--- /dev/null
@@ -0,0 +1,26 @@
+From 9d7a18a0491638944b64b69b0f9244a6eb98f6c4 Mon Sep 17 00:00:00 2001
+From: Yamakura Makoto <yakina@gentoo.org>
+Date: Thu, 18 Sep 2003 13:12:14 +1200
+Subject: Fix Makefile.PL for system inc/lib paths
+
+---
+ Makefile.PL | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 6640058..513dabc 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -6,7 +6,7 @@ use ExtUtils::MakeMaker;
+ WriteMakefile(
+             'NAME' => 'Text::Kakasi',
+             'VERSION_FROM' => 'Kakasi.pm',
+-            'INC' => '-I/usr/local/include',
+-            'LIBS' => ['-L/usr/local/lib -lkakasi'],
++            'INC' => '-I/usr/include',
++            'LIBS' => ['-L/usr/lib -lkakasi'],
+             'DEFINE' => '-DWAKATIGAKI',
+ );
+-- 
+2.16.2
+