dev-lang/erlang: fix lib/asn1 depend, bug #705500
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 17 Jan 2020 08:04:11 +0000 (08:04 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 17 Jan 2020 08:04:38 +0000 (08:04 +0000)
The build failure is reproducible on a 4-core CPU when using
massive parallelism:

```
$ make -j21 -l4
...
 GEN    asn1ct_eval_ext.erl
{"init terminating in do_boot",
  {undef,[{asn1ct_func,start_link,[],[]},
          {prepare_templates,gen_asn1ct_eval,1,
           [{file,"prepare_templates.erl"},{line,58}]},
            {init,start_it,1,[]},{init,start_em,1,[]}]}}
init terminating in do_boot ()

Crash dump is being written to: erl_crash.dump...done
make[2]: *** [Makefile:139: asn1ct_eval_ext.erl] Error 1
```

Here `asn1ct_eval_ext.erl` attempts to load `asn1ct_func.beam`
via `prepare_templates.erl` before it's compiled into `.beam` file.

The change pulls in a dependency on `asn1ct_func.beam`.

Reported-by: WGH
Closes: https://bugs.gentoo.org/705500
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-lang/erlang/erlang-22.1.4.ebuild
dev-lang/erlang/erlang-22.1.8-r1.ebuild
dev-lang/erlang/erlang-22.2.1-r1.ebuild
dev-lang/erlang/erlang-22.2.2.ebuild
dev-lang/erlang/erlang-22.2.ebuild
dev-lang/erlang/files/erlang-22.1.4-asn1-dep.patch [new file with mode: 0644]

index 83d78ce48e10239a65a9f05969ffa0b64b554ab0..a6aec6a1a12f3e92cae32a877bd518f1694c4f09 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -51,6 +51,7 @@ S="${WORKDIR}/otp-OTP-${PV}"
 PATCHES=(
        "${FILESDIR}/18.2.1-wx3.0.patch"
        "${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
+       "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
 )
 
 SITEFILE=50"${PN}"-gentoo.el
index 3ffd63edd06e95f74c22313d1ec0187366b2120e..5d1d119a757616d1c1e56e14615b15159eae98d4 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -51,6 +51,7 @@ S="${WORKDIR}/otp-OTP-${PV}"
 PATCHES=(
        "${FILESDIR}/18.2.1-wx3.0.patch"
        "${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
+       "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
 )
 
 SITEFILE=50"${PN}"-gentoo.el
index 3ffd63edd06e95f74c22313d1ec0187366b2120e..5d1d119a757616d1c1e56e14615b15159eae98d4 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -51,6 +51,7 @@ S="${WORKDIR}/otp-OTP-${PV}"
 PATCHES=(
        "${FILESDIR}/18.2.1-wx3.0.patch"
        "${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
+       "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
 )
 
 SITEFILE=50"${PN}"-gentoo.el
index 97a529061f4c6e64cc1d3b04ea3abfa01f76261c..c52ed00f231a4d2cd5e8d94d73c68161eee9f159 100644 (file)
@@ -52,6 +52,7 @@ PATCHES=(
        "${FILESDIR}/18.2.1-wx3.0.patch"
        "${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
        "${FILESDIR}/${PN}-22.2.2-gcc-10.patch"
+       "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
 )
 
 SITEFILE=50"${PN}"-gentoo.el
index 3ffd63edd06e95f74c22313d1ec0187366b2120e..5d1d119a757616d1c1e56e14615b15159eae98d4 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -51,6 +51,7 @@ S="${WORKDIR}/otp-OTP-${PV}"
 PATCHES=(
        "${FILESDIR}/18.2.1-wx3.0.patch"
        "${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
+       "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
 )
 
 SITEFILE=50"${PN}"-gentoo.el
diff --git a/dev-lang/erlang/files/erlang-22.1.4-asn1-dep.patch b/dev-lang/erlang/files/erlang-22.1.4-asn1-dep.patch
new file mode 100644 (file)
index 0000000..84c9b81
--- /dev/null
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/705500
+https://github.com/erlang/otp/pull/2508
+
+--- a/lib/asn1/src/Makefile
++++ b/lib/asn1/src/Makefile
+@@ -190,7 +190,8 @@ asn1rtt_%.$(EMULATOR): asn1rtt_%.erl
+       $(V_ERLC) +debug_info $<
+ $(EVAL_CT_MODULES:%=%.erl): prepare_templates.$(EMULATOR) \
+-                          $(EBIN)/asn1ct_rtt.$(EMULATOR)
++                          $(EBIN)/asn1ct_rtt.$(EMULATOR) \
++                          $(EBIN)/asn1ct_func.$(EMULATOR)
+ #
+ # Dependencies