media-sound/guitarix: use array to pass configure args
authorAlexander Tsoy <alexander@tsoy.me>
Thu, 6 Jun 2019 16:25:25 +0000 (19:25 +0300)
committerMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 11:49:09 +0000 (13:49 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.11
Signed-off-by: Alexander Tsoy <alexander@tsoy.me>
Closes: https://github.com/gentoo/gentoo/pull/12212
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-sound/guitarix/guitarix-0.38.1-r1.ebuild

index f087100afca31a947a3506ece0deb5d115056eff..ce38767c1e0c481ee4942127c64b75c89f1757a4 100644 (file)
@@ -54,20 +54,22 @@ DEPEND="${COMMON_DEPEND}
 DOCS=( changelog README )
 
 src_configure() {
-       waf-utils_src_configure \
-               --cxxflags-debug="" \
-               --cxxflags-release="-DNDEBUG" \
-               --ldflags="${LDFLAGS}" \
-               --enable-lfs \
-               --lib-dev \
-               --no-desktop-update \
-               --no-faust \
-               --no-ldconfig \
-               --shared-lib \
-               $(use_enable nls) \
-               $(usex bluetooth "" "--no-bluez") \
-               $(usex debug "--debug" "") \
-               $(usex lv2 "--lv2dir=${EPREFIX}/usr/$(get_libdir)/lv2" "--no-lv2 --no-lv2-gui") \
-               $(usex standalone "" "--no-standalone") \
+       local myconf=(
+               --cxxflags-debug=""
+               --cxxflags-release="-DNDEBUG"
+               --ldflags="${LDFLAGS}"
+               --enable-lfs
+               --lib-dev
+               --no-desktop-update
+               --no-faust
+               --no-ldconfig
+               --shared-lib
+               $(use_enable nls)
+               $(usex bluetooth "" "--no-bluez")
+               $(usex debug "--debug" "")
+               $(usex lv2 "--lv2dir=${EPREFIX}/usr/$(get_libdir)/lv2" "--no-lv2 --no-lv2-gui")
+               $(usex standalone "" "--no-standalone")
                $(usex zeroconf "" "--no-avahi")
+       )
+       waf-utils_src_configure "${myconf[@]}"
 }