dev-python/cvxopt: new version supporting newer pythons.
authorMichael Orlitzky <mjo@gentoo.org>
Sun, 19 Apr 2020 21:01:57 +0000 (17:01 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Sun, 19 Apr 2020 23:16:09 +0000 (19:16 -0400)
This new version 1.2.5 comes with an updated EAPI=7. This is a
prerequisite for adding python-3.7 and python-3.8 support to
sci-mathematics/dunshire.

Bug: https://bugs.gentoo.org/718502
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
dev-python/cvxopt/Manifest
dev-python/cvxopt/cvxopt-1.2.5.ebuild [moved from dev-python/cvxopt/cvxopt-1.1.9.ebuild with 86% similarity]

index 1da99b0701187ede596da3e730a3c6f9dfc955b5..068f2df5310718c042bad6383f224f378e99bc2b 100644 (file)
@@ -1 +1 @@
-DIST cvxopt-1.1.9.tar.gz 1872932 BLAKE2B 50990b8432d32db68580243a5f547a4be2fd36f23196b1505e90eccef9fab5526ea485bf9f81539842229eb276345edce12b064065a1e13125d5adca0de07e8c SHA512 bb0982cd1489157df4c7cd0dd92bf83b1692dc3a27d6b9a7a465dda9f9daea4ea5ef69e48642a879d036679bd0b0fe0dfd782433ce4cc570e90e11823733e58b
+DIST cvxopt-1.2.5.tar.gz 6742389 BLAKE2B 32e872d13624250610e7eecf2a5755b7b2adbf98dd9b7d1b0d6e236d62677fcdef7c08a2365d7b511f755a38b34a29ff78b280fb7e92ec6256a71c63e022e003 SHA512 d21d9977941140e76d1619a1239fab5d93a3467c4cbeacca2003168c96e1bbec9698563dba07107f6e0a84a0af92124d5c868af599bd049b64f47a3cd3753afc
similarity index 86%
rename from dev-python/cvxopt/cvxopt-1.1.9.ebuild
rename to dev-python/cvxopt/cvxopt-1.2.5.ebuild
index 992320c342b4bda735598e144fa4d82c3ed9d509..4f197405a30a2e27ed620290549d1370ec7c1f1f 100644 (file)
@@ -1,22 +1,23 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
 
 inherit distutils-r1 toolchain-funcs
 
 DESCRIPTION="Python package for convex optimization"
-HOMEPAGE="http://cvxopt.org/"
+HOMEPAGE="http://cvxopt.org/ https://github.com/cvxopt/cvxopt"
 SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc +dsdp examples fftw +glpk gsl"
+IUSE="doc +dsdp examples fftw +glpk gsl test"
+RESTRICT="!test? ( test )"
 
-RDEPEND="
+DEPEND="
        virtual/blas
        virtual/lapack
        sci-libs/amd:0=
@@ -28,9 +29,12 @@ RDEPEND="
        fftw? ( sci-libs/fftw:3.0= )
        glpk? ( >=sci-mathematics/glpk-4.49:0= )
        gsl? ( sci-libs/gsl:0= )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       doc? ( dev-python/sphinx )"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig
+       doc? ( dev-python/sphinx )
+       test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )"
 
 python_prepare_all() {
        pkg_libs() {
@@ -93,11 +97,9 @@ python_test() {
 
 python_install_all() {
        use doc && HTML_DOCS=( doc/build/html/. )
-       insinto /usr/share/doc/${PF}
        distutils-r1_python_install_all
        if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r examples
-               docompress -x /usr/share/doc/${PF}/examples
+               dodoc -r examples
+               docompress -x "/usr/share/doc/${PF}/examples"
        fi
 }