libs/vidstab: moving to EAPI=7
authorKalin KOZHUHAROV <me.kalin@gmail.com>
Tue, 19 Nov 2019 11:35:39 +0000 (12:35 +0100)
committerCraig Andrews <candrews@gentoo.org>
Tue, 19 Nov 2019 12:43:32 +0000 (07:43 -0500)
Bug: https://bugs.gentoo.org/700302
Signed-off-by: Kalin KOZHUHAROV <kalin@thinrope.net>
Closes: https://github.com/gentoo/gentoo/pull/13709
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-libs/vidstab/vidstab-1.1.0-r2.ebuild [new file with mode: 0644]
media-libs/vidstab/vidstab-9999.ebuild

diff --git a/media-libs/vidstab/vidstab-1.1.0-r2.ebuild b/media-libs/vidstab/vidstab-1.1.0-r2.ebuild
new file mode 100644 (file)
index 0000000..7f3c294
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+
+inherit cmake-multilib toolchain-funcs
+
+DESCRIPTION="Video stabilization library"
+HOMEPAGE="http://public.hronopik.de/vid.stab/"
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/georgmartius/vid.stab.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/georgmartius/vid.stab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+       S="${WORKDIR}/vid.stab-${PV}"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="openmp cpu_flags_x86_sse2"
+PATCHES=(
+       "${FILESDIR}/vidstab-1.1.0-tests-should-exit-with-code-0-on-success.patch"
+       "${FILESDIR}/vidstab-1.1.0-tests-use-sse2-only-if-available.patch"
+       "${FILESDIR}/vidstab-1.1.0-tests-1.1.0-fix-test_motiondetect-without-openmp.patch"
+)
+src_prepare() {
+       # USE=cpu_flags_x86_sse2 instead
+       sed -E 's#include (FindSSE)##' -i CMakeLists.txt || die
+       sed -E 's#include (FindSSE)##' -i tests/CMakeLists.txt || die
+       # strip some CFLAGS
+       for FILE_TO_PATCH in {,transcode/,tests/}CMakeLists.txt; do
+               sed -E 's#(add_definitions.* )-g #\1#' -i ${FILE_TO_PATCH} || die
+               sed -E 's#(add_definitions.* )-O3 #\1#' -i ${FILE_TO_PATCH} || die
+       done
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       use openmp && tc-check-openmp
+       local mycmakeargs=(
+               -DUSE_OMP="$(usex openmp)"
+               -DSSE2_FOUND="$(usex cpu_flags_x86_sse2)"
+       )
+       cmake-multilib_src_configure
+}
+
+multilib_src_test() {
+       local mycmakeargs=(
+               -DUSE_OMP="$(usex openmp)"
+               -DSSE2_FOUND="$(usex cpu_flags_x86_sse2)"
+       )
+       local CMAKE_USE_DIR="${CMAKE_USE_DIR}/tests"
+       local BUILD_DIR="${BUILD_DIR}/tests"
+       cmake-utils_src_configure
+       cmake-utils_src_make
+       "${BUILD_DIR}"/tests || die
+}
index 447fa85568696a25288fb170e997a2e68760c02f..f4bd05f45203bb54fed846fe601f29d97e141583 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 2018-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 : ${CMAKE_MAKEFILE_GENERATOR:=ninja}
 
@@ -15,7 +15,7 @@ if [[ ${PV} == *9999 ]] ; then
        inherit git-r3
 else
        SRC_URI="https://github.com/georgmartius/vid.stab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
+       KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
        S="${WORKDIR}/vid.stab-${PV}"
 fi