dev-vcs/hub: 2.6.1 version bump
authorWilliam Hubbs <williamh@gentoo.org>
Wed, 26 Dec 2018 22:17:17 +0000 (16:17 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Wed, 26 Dec 2018 22:18:27 +0000 (16:18 -0600)
Closes: https://bugs.gentoo.org/649974
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-vcs/hub/Manifest
dev-vcs/hub/hub-2.6.1.ebuild [new file with mode: 0644]

index f2b9895b229efeae07a65b70c8912877eac26ea3..56265704d82b67670c46ce341f6ea78d98683e31 100644 (file)
@@ -1 +1,3 @@
 DIST hub-2.2.9.tar.gz 318275 BLAKE2B 731c3bb4cc4d92082f93bba94a5cc7ba31fc436479655fa19ffa8078416cedd814d2667589af9d6eed59a0be0c8b38963779429838d8dbaab8a628f838a5915c SHA512 69d69683eb5f1c881b15c9b3294878c35edc51f9b7d568a3e0609c3d77cebf5c1be5c7c018b0356bdd68cf3f56691a860381a53f3e016b28b9f95ab0b852d9f9
+DIST hub-2.6.1.tar.gz 994752 BLAKE2B 956f497699ecaac996fd3a92e5f7042d8e72050077e1de3b6091fe5e2481d9b8e4c46a8e34a2a95a81079b22b87bf82e2a5adf412e4dfbcbc53bf92f8b7ba2fa SHA512 a3aed611455de88a5b410887717aeb28b8837a74b437848c53903ccc809e758678643471ee7b14903ee147417754b0d443aede63e4f69a0e4b252c6a5ab619e3
+DIST hub-linux-amd64-2.6.1.tgz 4242259 BLAKE2B b68234050982999f103281da974af9c008e85920c0821ecb5582bf97b0a4889f6dd053ab3e6c7c5a0e18d1b09c7093f69d70f46b94254e51b2e6eb217fe3f479 SHA512 e27d9b8037e50b924b7ef663d9f68568f2732ed28e366aa300881eeeb6a2bdd1f50b4e597e3d36eddb07eb9c133df02ab5f889d5c6ec8632824d244148524e9b
diff --git a/dev-vcs/hub/hub-2.6.1.ebuild b/dev-vcs/hub/hub-2.6.1.ebuild
new file mode 100644 (file)
index 0000000..78570a6
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN=github.com/github/hub
+inherit bash-completion-r1
+
+DESCRIPTION="Command-line wrapper for git that makes you better at GitHub"
+HOMEPAGE="https://github.com/github/hub"
+SRC_URI="https://github.com/github/hub/archive/v${PV}.tar.gz -> ${P}.tar.gz
+       https://${EGO_PN}/releases/download/v${PV}/${PN}-linux-amd64-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.5.1:="
+RDEPEND=">=dev-vcs/git-1.7.3"
+
+QA_FLAGS_IGNORED=".*"
+RESTRICT="strip"
+
+src_prepare() {
+       mkdir -p "${HOME}/go/src/${EGO_PN%/*}" || die "mkdir failed"
+       ln -snf "${S}" "${HOME}/go/src/${EGO_PN}" || die "ln failed"
+       default
+}
+
+src_compile() {
+       ./script/build -o bin/${PN} || die
+}
+
+#src_test() {
+#      ./script/test || die
+#}
+
+src_install() {
+       dobin bin/${PN}
+       dodoc README.md
+       doman ../${PN}-linux-amd64-${PV}/share/man/man1/*.1
+
+       newbashcomp etc/${PN}.bash_completion.sh ${PN}
+
+       insinto /usr/share/zsh/site-functions
+       newins etc/hub.zsh_completion _${PN}
+}