net-misc/ntpsec: add upstream patch and expand py3 compat
authorStephen Arnold <nerdboy@gentoo.org>
Mon, 9 Mar 2020 23:54:18 +0000 (16:54 -0700)
committerStephen Arnold <nerdboy@gentoo.org>
Tue, 10 Mar 2020 00:01:50 +0000 (17:01 -0700)
* closes bugs #709258 and #710414

Package-Manager: Portage-2.3.67, Repoman-2.3.17
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
net-misc/ntpsec/files/ntpsec-1.1.8-externalize-sys_maxclock-fix-for-bug-708522.patch [new file with mode: 0644]
net-misc/ntpsec/ntpsec-1.1.8.ebuild
net-misc/ntpsec/ntpsec-9999.ebuild

diff --git a/net-misc/ntpsec/files/ntpsec-1.1.8-externalize-sys_maxclock-fix-for-bug-708522.patch b/net-misc/ntpsec/files/ntpsec-1.1.8-externalize-sys_maxclock-fix-for-bug-708522.patch
new file mode 100644 (file)
index 0000000..caeaf18
--- /dev/null
@@ -0,0 +1,23 @@
+From ccdd9d4b941b30fc44b301595e42809dbe48628d Mon Sep 17 00:00:00 2001
+From: James Browning <JamesB.fe80@gmail.com>
+Date: Sun, 26 Jan 2020 09:58:36 -0800
+Subject: [PATCH] Externalize sys_maxclock from include/ntpd.h ...
+
+I think this will shut up the Fedora Rawhide runners
+---
+ include/ntpd.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/ntpd.h b/include/ntpd.h
+index c4f9b9e45..ee16678e1 100644
+--- a/include/ntpd.h
++++ b/include/ntpd.h
+@@ -369,7 +369,7 @@ extern int peer_associations;      /* mobilized associations */
+  * System variables are declared here.        See Section 3.2 of the
+  * specification.
+  */
+-int   sys_maxclock;           /* maximum candidates */
++extern int    sys_maxclock;           /* maximum candidates */
+ struct system_variables {
+       uint8_t sys_leap;               /* system leap indicator */
+       uint8_t sys_stratum;            /* system stratum */
index 1316806dc69d3e0cfd8db34b901a0fc561617b3b..128e2a23826c1c8b1a3d49edb3719b3db1b0c6a0 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE='threads(+)'
 
 inherit flag-o-matic python-r1 waf-utils systemd
@@ -62,6 +62,8 @@ DEPEND="${CDEPEND}
 
 WAF_BINARY="${S}/waf"
 
+PATCHES=( "${FILESDIR}/${P}-externalize-sys_maxclock-fix-for-bug-708522.patch" )
+
 src_prepare() {
        default
        # Remove autostripping of binaries
index 1316806dc69d3e0cfd8db34b901a0fc561617b3b..36dc8d080881186e25e15a9e581a1d0f876bff23 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE='threads(+)'
 
 inherit flag-o-matic python-r1 waf-utils systemd