dev-python/yaql: bup
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 2 Mar 2017 18:18:36 +0000 (12:18 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 2 Mar 2017 18:18:36 +0000 (12:18 -0600)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/yaql/Manifest
dev-python/yaql/yaql-1.1.3.ebuild [new file with mode: 0644]

index d7b0e8c66cd06d23bbc56f89ddd99be249f2f7a1..623d166cce1183502e8dc820019769f1e245106c 100644 (file)
@@ -1 +1,2 @@
 DIST yaql-1.1.1.tar.gz 68366 SHA256 2e06a56e39da21765306e4709cd87ec3ed366223badc95499576f0662f69a04c SHA512 07e41e58d85a357f7b980501501558d50264a7e3c9b81b0117e3bd202ac06bd562d1b4ea505a613ed11051f5e45ae1687f010a3c75d2f9dbff673f81a04644e9 WHIRLPOOL 8adef15359e80070d15022162b4b0ade6df15e6350c20d966a46109adda17b1e9e7db31a1b68a55c1b96eee683f5a06fd7c13f29656924d10556224218a6aaaf
+DIST yaql-1.1.3.tar.gz 111546 SHA256 1134d9e9a8b61c97ac03f80d27fa60439397a6ff7aac3c3180c0a6908c05d209 SHA512 e85712f65dc932126c75cc84403d14639f76098f4bd22ff2106a68afb6685794e1797154bbf1343e1f82a8b4a13e351d2d0dec1f235e31eecd96f6394116cd4b WHIRLPOOL 12f203d7aa863df727dc6fbc241694bea1f9f4e9df61d1b417d1275945b63254394d001d4441939118026eed516403421751d473f2825702166209d17a5d1e9a
diff --git a/dev-python/yaql/yaql-1.1.3.ebuild b/dev-python/yaql/yaql-1.1.3.ebuild
new file mode 100644 (file)
index 0000000..388ce33
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="YAQL: Yet Another Query Language"
+HOMEPAGE="https://github.com/openstack/yaql"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+       dev-python/ply[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"