media-video/handbrake: Dont search for python
authorIan Whyman <thev00d00@gentoo.org>
Wed, 20 Nov 2019 18:23:56 +0000 (18:23 +0000)
committerIan Whyman <thev00d00@gentoo.org>
Wed, 20 Nov 2019 18:24:16 +0000 (18:24 +0000)
The ebuild would prefer calling python3 even if the eclass had chosen a
2.7 version, upsetting python_wrapper_setup

Closes: https://bugs.gentoo.org/700706
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
media-video/handbrake/files/handbrake-1.3.0-dont-search-for-python.patch [new file with mode: 0644]
media-video/handbrake/handbrake-1.3.0-r2.ebuild [moved from media-video/handbrake/handbrake-1.3.0-r1.ebuild with 97% similarity]

diff --git a/media-video/handbrake/files/handbrake-1.3.0-dont-search-for-python.patch b/media-video/handbrake/files/handbrake-1.3.0-dont-search-for-python.patch
new file mode 100644 (file)
index 0000000..551a64e
--- /dev/null
@@ -0,0 +1,27 @@
+diff --git a/configure b/configure
+index 5c870e1d7..2f5834083 100755
+--- a/configure
++++ b/configure
+@@ -14,20 +14,8 @@ inpath()
+ }
+ if ( inpath bash ); then
+-    pp=""
+-    for p in python3 python3.8 python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python2 python2.7 python
+-    do
+-        if ( inpath $p ); then
+-            pp="$p"
+-            break
+-        fi
+-    done
+-    if [ pp != "" ]; then
+-        exec $pp `dirname $0`/make/configure.py "$@"
+-        exit 0
+-    else
+-        echo "ERROR: no suitable version of python found."
+-    fi
++    exec python `dirname $0`/make/configure.py "$@"
++    exit 0
+ else
+     echo "ERROR: bash shell not found."
+ fi
similarity index 97%
rename from media-video/handbrake/handbrake-1.3.0-r1.ebuild
rename to media-video/handbrake/handbrake-1.3.0-r2.ebuild
index ddd530597452d5c2963a3cecc7cf9aabed57661f..21bb95bbbdbb27c4ed1e55dde704f2215350ab7d 100644 (file)
@@ -90,11 +90,10 @@ PATCHES=(
 
        # Fix missing flags
        "${FILESDIR}/${P}-missing-linker-flags.patch"
-)
 
-pkg_setup() {
-       python-any-r1_pkg_setup
-}
+       # Use whichever python is set by portage
+       "${FILESDIR}/${P}-dont-search-for-python.patch"
+)
 
 src_prepare() {
        # Get rid of leftover bundled library build definitions,