sys-process/acct: Rename logrotate script (bug #542906)
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 22 Sep 2017 21:24:17 +0000 (23:24 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 22 Sep 2017 21:33:38 +0000 (23:33 +0200)
sys-process/atop checks for "/etc/logrotate.d/psacct" but we named
the script just "acct".

Package-Manager: Portage-2.3.8, Repoman-2.3.3

sys-process/acct/acct-6.6.4-r1.ebuild [new file with mode: 0644]

diff --git a/sys-process/acct/acct-6.6.4-r1.ebuild b/sys-process/acct/acct-6.6.4-r1.ebuild
new file mode 100644 (file)
index 0000000..efc32e5
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools systemd
+
+DESCRIPTION="GNU system accounting utilities"
+HOMEPAGE="https://savannah.gnu.org/projects/acct/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-6.6.4-cross-compile.patch
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf --enable-linux-multiformat
+}
+
+src_install() {
+       default
+       keepdir /var/account
+       newinitd "${FILESDIR}"/acct.initd-r2 acct
+       newconfd "${FILESDIR}"/acct.confd-r1 acct
+       systemd_dounit "${FILESDIR}"/acct.service
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}"/acct.logrotate-r1 psacct
+
+       # sys-apps/sysvinit already provides this
+       rm "${ED}"/usr/bin/last "${ED}"/usr/share/man/man1/last.1 || die
+
+       # accton in / is only a temp workaround for #239748
+       dodir /sbin
+       mv "${ED}"/usr/sbin/accton "${ED}"/sbin/ || die
+}