dev-util/catkin: Add pypy3 support
authorAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 09:34:50 +0000 (10:34 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 09:44:52 +0000 (10:44 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-util/catkin/catkin-0.7.6.ebuild
dev-util/catkin/catkin-9999.ebuild

index 2bce0e1b502d34b1718a512b7cf511f23c6c721f..883e9a8828a209ef8f3064c0b0833cbd4e4cf015 100644 (file)
@@ -10,7 +10,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
        EGIT_REPO_URI="https://github.com/ros/catkin"
 fi
 
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
 
 inherit ${SCM} cmake-utils python-r1 python-utils-r1
 
index 2bce0e1b502d34b1718a512b7cf511f23c6c721f..883e9a8828a209ef8f3064c0b0833cbd4e4cf015 100644 (file)
@@ -10,7 +10,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
        EGIT_REPO_URI="https://github.com/ros/catkin"
 fi
 
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
 
 inherit ${SCM} cmake-utils python-r1 python-utils-r1