sys-cluster/ceph-14.2.9: Drop boost-soname patch for sed
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 23 Apr 2020 20:04:52 +0000 (13:04 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 23 Apr 2020 20:44:21 +0000 (13:44 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
sys-cluster/ceph/ceph-14.2.9.ebuild

index 95abd364b0f5e3b48c2b848f12209fd30a1767e5..75b01167a7165e4962c87bd79b50d0106ab5174d 100644 (file)
@@ -197,12 +197,10 @@ src_prepare() {
        cmake-utils_src_prepare
 
        if use system-boost; then
-               eapply "${FILESDIR}/ceph-14.2.8-boost-sonames.patch"
-
                find "${S}" -name '*.cmake' -or -name 'CMakeLists.txt' -print0 \
                        | xargs --null sed \
-                       -e 's|Boost::|Boost_|g' \
-                       -e 's|Boost_boost|boost_system|g' -i || die
+                       -e 's|Boost::|boost_|g' \
+                       -e 's|boost_boost|boost_system|g' -i || die
        fi
 
        sed -i -r "s:DESTINATION .+\\):DESTINATION $(get_bashcompdir)\\):" \