dev-python/pmw: Remove old
authorDavid Seifert <soap@gentoo.org>
Thu, 19 Mar 2020 22:12:32 +0000 (23:12 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 19 Mar 2020 22:12:32 +0000 (23:12 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/pmw/pmw-2.0.1.ebuild [deleted file]

diff --git a/dev-python/pmw/pmw-2.0.1.ebuild b/dev-python/pmw/pmw-2.0.1.ebuild
deleted file mode 100644 (file)
index c369639..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="tk"
-
-inherit distutils-r1 virtualx
-
-MY_PN="Pmw"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Toolkit for building high-level compound widgets in Python using the Tkinter module"
-HOMEPAGE="http://pmw.sourceforge.net/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="py3"
-KEYWORDS="~alpha amd64 ia64 ppc sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-DEPEND="!dev-python/pmw:0"
-RDEPEND="${DEPEND}"
-# https://sourceforge.net/p/pmw/bugs/39/
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare() {
-       2to3 Pmw || die
-}
-
-python_test() {
-       VIRTUALX_COMMAND="${PYTHON}"
-       cd "${BUILD_DIR}/lib/Pmw/Pmw_${PV//./_}/" || die
-       cp tests/{flagup.bmp,earthris.gif} . || die
-       for test in tests/*_test.py; do
-               echo "running test "$test
-               PYTHONPATH=tests:../../ virtualmake $test || die
-       done
-}
-
-python_install_all() {
-       local DIR="Pmw/Pmw_${PV//./_}"
-
-       use doc && HTML_DOCS=( "${DIR}"/doc/. )
-       use examples && EXAMPLES=( "${DIR}"/demos/. )
-
-       distutils-r1_python_install_all
-}